summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-01-22 23:54:26 +0100
committerGuido Günther <agx@sigxcpu.org>2010-01-22 23:54:26 +0100
commit36762c33bf05774e9f40ebd318b4749c69b28ac3 (patch)
treead9a04f4dc1927fb1dac808547a6afbcf2230cc1
parent3f5a6babb02b56298eb7fb118dc23582cbff932a (diff)
Apply patch NMUdiff from Aurelien Jarno
Fixes build problems against newer e2fslibs Thanks: a lot
-rw-r--r--arclib/string.c33
-rw-r--r--debian/changelog16
-rw-r--r--debian/po/vi.po26
3 files changed, 61 insertions, 14 deletions
diff --git a/arclib/string.c b/arclib/string.c
index 1c424c0..66ed3c1 100644
--- a/arclib/string.c
+++ b/arclib/string.c
@@ -149,3 +149,36 @@ void __bzero(char *p, int len)
{
memset(p, 0, len);
}
+
+char *strcat(char *dest, const char *src)
+{
+ char *tmp = dest;
+
+ while (*dest)
+ dest++;
+ while ((*dest++ = *src++) != '\0')
+ ;
+ return tmp;
+}
+
+void *memmove(void *dest, const void *src, size_t count)
+{
+ char *tmp;
+ const char *s;
+
+ if (dest <= src) {
+ tmp = dest;
+ s = src;
+ while (count--)
+ *tmp++ = *s++;
+ } else {
+ tmp = dest;
+ tmp += count;
+ s = src;
+ s += count;
+ while (count--)
+ *--tmp = *--s;
+ }
+ return dest;
+}
+
diff --git a/debian/changelog b/debian/changelog
index 1b04c41..7fc9d7e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+arcboot (0.3.12+nmu1) unstable; urgency=low
+
+ * Non-maintainer upload with maintainer approval.
+
+ [ Aurelien Jarno ]
+ * Add strcat() and memmove() to arclib/string.c, taken from kernel
+ sources. (Closes: #564237)
+
+ [ Christian Perrier ]
+ * Fix pending l10n issues. Debconf translations:
+ * Vietnamese (Clytie Siddall). (Closes: #509712)
+ * Brazilian Portuguese (Eder L. Marques (frolic)). (Closes: #511883)
+ * Simplified Chinese (Ji ZhengYu). (Closes: #562063)
+
+ -- Aurelien Jarno <aurel32@debian.org> Tue, 12 Jan 2010 09:14:33 +0000
+
arcboot (0.3.12) unstable; urgency=low
* [1b7d979] Update cs translation (Closes: #499590) - thanks to Miroslav
diff --git a/debian/po/vi.po b/debian/po/vi.po
index 4bd7ca9..f2fd479 100644
--- a/debian/po/vi.po
+++ b/debian/po/vi.po
@@ -1,25 +1,26 @@
# Vietnamese translation for arcboot.
-# Copyright © 2005 Free Software Foundation, Inc.
-# Clytie Siddall <clytie@riverland.net.au>, 2005.
+# Copyright © 2008 Free Software Foundation, Inc.
+# Clytie Siddall <clytie@riverland.net.au>, 2005-2008.
#
msgid ""
msgstr ""
-"Project-Id-Version: arcboot 0.3.8.6\n"
+"Project-Id-Version: arcboot 0.3.11+nmu1\n"
"Report-Msgid-Bugs-To: arcboot@packages.debian.org\n"
"POT-Creation-Date: 2008-01-24 14:06+0000\n"
-"PO-Revision-Date: 2005-06-12 11:33+0930\n"
+"PO-Revision-Date: 2008-12-25 16:49+1030\n"
"Last-Translator: Clytie Siddall <clytie@riverland.net.au>\n"
-"Language-Team: Vietnamese <gnomevi-list@lists.sourceforge.net>\n"
+"Language-Team: Vietnamese <vi-VN@googlegroups.com>\n"
"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=utf-8\n"
+"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=1; plural=0\n"
+"Plural-Forms: nplurals=1; plural=0;\n"
+"X-Generator: LocFactoryEditor 1.8\n"
#. Type: string
#. Description
#: ../templates:1001
msgid "Location of arcboot:"
-msgstr ""
+msgstr "Vị trí của arcboot"
#. Type: string
#. Description
@@ -29,9 +30,6 @@ msgid ""
"Usually the volume header of /dev/sda is used. Please give the device name "
"of the disk you want to put arcboot onto."
msgstr ""
-"Phải để trình arcboot vào phần đầu khối tin của một đĩa có nhãn đĩa SGI. "
-"Thường dùng phần đầu khối tin của «/dev/sda». Hãy nhập tên thiết bị của đĩa "
-"nơi bạn muốn để trình arcboot."
-
-#~ msgid "Where to put arcboot?"
-#~ msgstr "Bạn có muốn để trình arcboot vào chỗ nào?"
+"Phần mềm arcboot phải nằm trong phần đầu khối tin của một đĩa có nhãn đĩa "
+"SGI. Bình thường dùng phần đầu khối tin của « /dev/sda ». Hãy gõ tên thiết bị "
+"của đĩa trên đó bạn muốn để arcboot."