summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-06-16 22:13:53 +0200
committerGuido Günther <agx@sigxcpu.org>2011-06-16 23:37:57 +0200
commit399eff17bd4de7663bbf2914e59a7d3a99ccc153 (patch)
tree41ff7a901ad2903a9114b0678a937aba69af034d
parent01c99b53048b4d436eb55e9bf22414610f17d057 (diff)
Fix address substitution for IP32
it was being handled as IP22 in tip22
-rw-r--r--Makefile6
-rw-r--r--common/version.h2
-rwxr-xr-xdebian/rules3
-rw-r--r--tip22/Makefile24
4 files changed, 8 insertions, 27 deletions
diff --git a/Makefile b/Makefile
index b818247..28c35ef 100644
--- a/Makefile
+++ b/Makefile
@@ -24,13 +24,13 @@ endif
# these contain subarch independent files
SUBARCH_INDEP_DIRS= \
- arclib \
- tip22
+ arclib
# these contain subarch dependent files
SUBARCH_DIRS= \
common \
- ext2load
+ ext2load \
+ tip22
define indep-tgt
$(foreach sd,$(SUBARCH_INDEP_DIRS),$(1)-subarch-indep-$(sd))
diff --git a/common/version.h b/common/version.h
index 8a2150f..bb8207f 100644
--- a/common/version.h
+++ b/common/version.h
@@ -1 +1 @@
-#define __ARCSBOOT_VERSION__ "0.3.9.1"
+#define __ARCSBOOT_VERSION__ "0.3.13"
diff --git a/debian/rules b/debian/rules
index e003fda..b7eee9a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -63,7 +63,8 @@ install: build
# install tip22 into debian/tip22
$(MAKE) PREFIX=${PREFIX_TIP22} BINDIR=${BIN_TIP22} LIBDIR=${LIB_TIP22} -C arclib install
- $(MAKE) PREFIX=${PREFIX_TIP22} BINDIR=${BIN_TIP22} LIBDIR=${LIB_TIP22} -C tip22 install
+ $(MAKE) SUBARCH=IP22 PREFIX=${PREFIX_TIP22} BINDIR=${BIN_TIP22} LIBDIR=${LIB_TIP22} -C tip22 install
+ $(MAKE) SUBARCH=IP32 PREFIX=${PREFIX_TIP22} BINDIR=${BIN_TIP22} LIBDIR=${LIB_TIP22} -C tip22 install
# Install lintian overrides
cp debian/arcboot.lintian-overrides $(CURDIR)/debian/arcboot/usr/share/lintian/overrides/arcboot
diff --git a/tip22/Makefile b/tip22/Makefile
index 1df2fb2..16031e5 100644
--- a/tip22/Makefile
+++ b/tip22/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright 2002-2004 Guido Guenther <agx@sigxcpu.org>
+# Copyright 2002-2004,2011 Guido Guenther <agx@sigxcpu.org>
#
ARCLIBDIR = ../arclib
@@ -24,21 +24,11 @@ TARGETS = $(OBJECTS) $(LD_SCRIPTS)
# uncomment for debugging
#CFLAGS+=-DDEBUG
-
-all: ${LIBS} ${BINS}
- @$(MAKE) SUBARCH=IP32 archall
- @$(MAKE) SUBARCH=IP22 archall
-
-archall: $(TARGETS)
-
+all: ${LIBS} ${BINS} $(TARGETS)
$(ARCLIB):
@$(MAKE) -C $(ARCLIBDIR)
-$(PRINT_LOADADDR):
- @$(MAKE) -C $(COMMONDIR) SUBARCH=$(SUBARCH)
-
-
%.$(SUBARCH).o: %.c
$(CC) $(CFLAGS) -c -o $@ $<
@@ -49,22 +39,12 @@ $(PRINT_LOADADDR):
-e "s/@@OUTPUTFORMAT@@/$$OUTPUTFORMAT/" <$< >$@
clean:
- @$(MAKE) SUBARCH=IP32 archclean
- @$(MAKE) SUBARCH=IP22 archclean
rm -f tags *~
-
-archclean:
- @$(MAKE) -C $(ARCLIBDIR) clean
- @$(MAKE) -C $(COMMONDIR) clean
rm -f $(TARGETS)
install: all
install -d ${PREFIX}/${BINDIR}
install -m 755 ${BINS} ${PREFIX}/${BINDIR}
- @$(MAKE) SUBARCH=IP32 archinstall
- @$(MAKE) SUBARCH=IP22 archinstall
-
-archinstall:
$(foreach tg,$(TARGETS),install -m 644 $(tg) ${PREFIX}/${LIBDIR};)