aboutsummaryrefslogtreecommitdiff
Commit message (Expand)AuthorAge
* [PATCH] Bump version to 0.16HEADversion_0.16masterPavel Roskin2007-07-15
* [PATCH] Update kernel patch for current wireless-dev.gitPavel Roskin2007-07-15
* [PATCH] Remove "a short overview on Ethernet-II, 802.2, 802.3 and SNAP"Pavel Roskin2007-07-15
* [PATCH] Clean up eth frame conversion in the rx pathPavel Roskin2007-07-15
* [PATCH] Clean up handling of ethernet frames in the tx pathPavel Roskin2007-07-15
* [PATCH] Fix sloppiness in debug directivesPavel Roskin2007-07-15
* [PATCH] Replace at76_assert with standard WARN_ON and BUG_ON macrosPavel Roskin2007-07-15
* [PATCH] Don't print misleading messages about unexpected framesPavel Roskin2007-07-15
* [PATCH] Improve formatting of the headers, use tabs where possiblePavel Roskin2007-07-15
* [PATCH] Use is_broadcast_ether_addr() where appropriatePavel Roskin2007-07-15
* [PATCH] Protect firmware loading with a mutexPavel Roskin2007-07-15
* [PATCH] Avoid __LINE__ in debug messagesPavel Roskin2007-07-15
* [PATCH] Avoid large "if" blocks to make code more readablePavel Roskin2007-07-15
* [PATCH] Improve comments, reorder some fields in at76_usb.hPavel Roskin2007-07-15
* [PATCH] Remove priv->open_count, it's write-onlyPavel Roskin2007-07-15
* [PATCH] Update documentationPavel Roskin2007-07-15
* [PATCH] Don't fill write_urb in at76_alloc_urbs()Pavel Roskin2007-07-15
* [PATCH] Eliminate priv->rx_urb, it shouldn't be therePavel Roskin2007-07-15
* [PATCH] Make at76_dump_mib_mac_wep() more readablePavel Roskin2007-07-15
* [PATCH] Make at76_match_mode() more readablePavel Roskin2007-07-15
* [PATCH] Eliminate unneeded comma operatorPavel Roskin2007-07-15
* [PATCH] Remove unused priv->ctrl_urb and priv->ctrl_bufferPavel Roskin2007-07-15
* [PATCH] Remove rx_copybreak, act as if it's 0Pavel Roskin2007-07-15
* [PATCH] Use more definitions from net/ieee80211.h and linux/if_ether.hPavel Roskin2007-07-15
* [PATCH] Use __func__ in debug messagesPavel Roskin2007-07-15
* [PATCH] Comment changes for at76_init_new_device() and at76_init_new_device()Pavel Roskin2007-07-15
* [PATCH] Move usb_put_dev() further to the end of at76_delete_device()Pavel Roskin2007-07-15
* [PATCH] Expand request type macros in usb_control_msg() callsPavel Roskin2007-07-15
* [PATCH] Make firmware download utilities more uniformPavel Roskin2007-07-15
* [PATCH] Don't use GFP_DMA, it's for ISA devicesPavel Roskin2007-07-15
* [PATCH] Actually use onoff parameter in at76_set_iroaming()Pavel Roskin2007-07-15
* [PATCH] Make it clear why we are adding 4 to buf->size in at76_set_mib()Pavel Roskin2007-07-15
* [PATCH] Give plain http URL for the firmware, not httpsPavel Roskin2007-07-15
* [PATCH] Convert skb compatibility code from functions to macrosPavel Roskin2007-07-15
* [PATCH] Convert management timer/work to a delayed workPavel Roskin2007-06-26
* [PATCH] Rename get_hw_cfg_intersil() to at76_get_hw_cfg_intersil()Pavel Roskin2007-06-26
* [PATCH] Rename set_group_address to at76_set_group_address, clean it upPavel Roskin2007-06-26
* [PATCH] Rename functions ending with "matched" to start with "at76_match"Pavel Roskin2007-06-26
* [PATCH] Don't print hex numbers starting with "x", use more common "0x"Pavel Roskin2007-06-26
* [PATCH] Re-examine and simplify code where "return" is followed by "else"Pavel Roskin2007-06-26
* [PATCH] Avoid assignments inside conditions, they are hard to readPavel Roskin2007-06-26
* [PATCH] Implement 5 second timeout in at76_wait_completion()Pavel Roskin2007-06-26
* [PATCH] Remove unneeded parentheses when taking an addressPavel Roskin2007-06-26
* [PATCH] Minor comment fixesPavel Roskin2007-06-26
* [PATCH] Replace a work/timer combination for restarts with a delayed workPavel Roskin2007-06-26
* [PATCH] Fix recent breakage in at76_set_listen_interval()Pavel Roskin2007-06-26
* [PATCH] Clean up code for internal firmware downloadPavel Roskin2007-06-16
* [PATCH] Eliminate struct dfu_ctxPavel Roskin2007-06-16
* [PATCH] Simplify at76_set_card_command()Pavel Roskin2007-06-16
* [PATCH] Reuse at76_set_card_command() from at76_set_mib()Pavel Roskin2007-06-16