aboutsummaryrefslogtreecommitdiff
Commit message (Expand)AuthorAge
...
* [PATCH] Use consistent timeout in usb_control_msg()Pavel Roskin2007-06-16
* [PATCH] Remove unneeded parentheses and operators when accessing "packet" fieldPavel Roskin2007-06-16
* [PATCH] Always use cpu_to_le16 to populate priv->mib_buf.data with 16-bit dataPavel Roskin2007-06-16
* [PATCH] Eliminate macros containing offsetof for MIB structuresPavel Roskin2007-06-16
* [PATCH] Add full support for "auto" preamblePavel Roskin2007-06-16
* [PATCH] Implement "get" counterparts for iwpriv callsPavel Roskin2007-06-16
* [PATCH] Use usb_make_path() for bus info in ethtool outputPavel Roskin2007-06-14
* [PATCH] Change SET_NET_DEVICE to use interface->devPavel Roskin2007-06-14
* [PATCH] Improve info messages, avoid printing full pathPavel Roskin2007-06-14
* [PATCH] Save results of usb_sndbulkpipe() and usb_rcvbulkpipe()Pavel Roskin2007-06-14
* [PATCH] Run at76_usb.c throut LindentPavel Roskin2007-06-14
* [PATCH] Simplify capability setting in (re)accociation requestsPavel Roskin2007-06-14
* [PATCH] Convert wireless handler initialization to use a macroPavel Roskin2007-06-14
* [PATCH] Don't use double newline to separate functionsPavel Roskin2007-06-14
* [PATCH] Fix more instances of bad formattingPavel Roskin2007-06-14
* [PATCH] Simplify dumping hex dataPavel Roskin2007-06-14
* [PATCH] Add compat.h to the source file list in MakefilePavel Roskin2007-06-14
* [PATCH] Put copyright into compat.hPavel Roskin2007-06-14
* [PATCH] Provide compatibility for older kernels in a separate filePavel Roskin2007-06-14
* [PATCH] Remove module parameters for the settings controlled by iwprivPavel Roskin2007-06-14
* [PATCH] Don't use workqueue to reschedule IBSS creationPavel Roskin2007-06-14
* [PATCH] Don't keep priv->interface, use USB interface provided in at76_probe()Pavel Roskin2007-06-09
* [PATCH] Decouple networking from firmware downloadPavel Roskin2007-06-09
* [PATCH] Fully separate scanning and monitoringPavel Roskin2007-06-05
* [PATCH] Remove at76_ieee80211_fixup(), it's not usedPavel Roskin2007-06-05
* [PATCH] Align all labels at position 6, as Lindent would doPavel Roskin2007-06-05
* [PATCH] Run unexpand on at76_usb.c to convert spaces to tabs when possiblePavel Roskin2007-06-05
* [PATCH] Run at76_usb.h through LindentPavel Roskin2007-06-05
* [PATCH] Call at76_set_monitor_mode() from at76_startup_device()Pavel Roskin2007-06-05
* [PATCH] Remove support for channel scanning in monitor modePavel Roskin2007-06-05
* [PATCH] Don't document endianess in comments, it's documented by the typePavel Roskin2007-06-05
* [PATCH] Rename request structures to make them distinct from functionsPavel Roskin2007-06-05
* [PATCH] Merge at76_handle_mgmt_timeout() and at76_work_mgmt_timeout()Pavel Roskin2007-06-05
* [PATCH] Failure in init shouldn't call at76_delete_device(), it's done laterPavel Roskin2007-06-03
* [PATCH] at76_delete_device() already calls usb_put_dev(), don't do it againPavel Roskin2007-06-03
* [PATCH] Use schedule_timeout_interruptible()Pavel Roskin2007-06-03
* [PATCH] Delete all timers on disconnect to be safePavel Roskin2007-06-03
* [PATCH] Internal firmware download should just sleep without any timersPavel Roskin2007-06-03
* [PATCH] Don't ignore errors during firmware downloadPavel Roskin2007-06-03
* [PATCH] Don't reschedule firmware loadingPavel Roskin2007-06-03
* [PATCH] Release priv->mtx when registering network devicePavel Roskin2007-06-03
* [PATCH] op_mode should be int, negative values are valid and mean an errorPavel Roskin2007-06-03
* [PATCH] Remove another unneeded castPavel Roskin2007-06-03
* [PATCH] Rename tasklet to rx_tasklet, the former is too genericPavel Roskin2007-06-03
* [PATCH] Update for the forthcoming Linux 2.6.22 skb APIPavel Roskin2007-05-13
* [PATCH] Replace semaphores with mutexesPavel Roskin2007-05-02
* [PATCH] Call private data (at76_priv) "priv", not "dev", the later is ambiguousPavel Roskin2007-05-02
* [PATCH] Never call net_device "dev", call it "netdev" for readabilityPavel Roskin2007-05-02
* [PATCH] Reorder the functions to avoid most forward declarationsPavel Roskin2007-05-02
* [PATCH] Rename at76_get_fw_info() to at76_parse_fw(), fully rewritePavel Roskin2007-05-02