aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAge
* [PATCH] Bump version to 0.16HEADversion_0.16masterPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Update kernel patch for current wireless-dev.gitPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove "a short overview on Ethernet-II, 802.2, 802.3 and SNAP"Pavel Roskin2007-07-15
| | | | | | It's way too big for a comment and doesn't belong to the source code. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Clean up eth frame conversion in the rx pathPavel Roskin2007-07-15
| | | | | | | | | | Stop badmouthing the implementations and follow the standard for 802.3 frames. Make it clear that if the ethernet header already exists, it was done by the local hardware (i.e. it's not an encapsulation method). Use eth_type_trans() to set skb->protocol. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Clean up handling of ethernet frames in the tx pathPavel Roskin2007-07-15
| | | | | | | Use more standard definitions for ethernet frames. Fix peeking beyond the end of skb for pathologically short frames. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Fix sloppiness in debug directivesPavel Roskin2007-07-15
| | | | | | | | Don't use double space as separator. Don't print hex data without leading "0x", except in data dumps and MAC addresses. Add spaces in expressions. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Replace at76_assert with standard WARN_ON and BUG_ON macrosPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't print misleading messages about unexpected framesPavel Roskin2007-07-15
| | | | | | | | | | | "mgmt, but not beacon" is wrong, as we handle more than just beacons. Print full framectl, and tell the user it's framectl, not a "frame from mars". Use KERN_DEBUG for both messages, as there are many weird frames on the air, and we don't want to pollute the console unnecessarily. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Improve formatting of the headers, use tabs where possiblePavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Use is_broadcast_ether_addr() where appropriatePavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Protect firmware loading with a mutexPavel Roskin2007-07-15
| | | | | | | Otherwise, two devices could try to load and parse the same firmware at the same time. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Avoid __LINE__ in debug messagesPavel Roskin2007-07-15
| | | | | | | Printing line number can be misleading. Limit it to the messages that are not unique throughout the code. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Avoid large "if" blocks to make code more readablePavel Roskin2007-07-15
| | | | | | | | Move shorter branches on top if they handle an error or just exit for whatever reason. This way, the longer branches are not indented and there are no distracting blocks around that code. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Improve comments, reorder some fields in at76_usb.hPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove priv->open_count, it's write-onlyPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Update documentationPavel Roskin2007-07-15
| | | | | | | | | | Change the interface name. It's ethX now, not wlanX. Update iwpriv names. Remove the section about module parameters, since they are gone (except "debug", but it's also on the way out). iwconfig requires "power" twice on the command line to enable power management and set listen interval at once. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't fill write_urb in at76_alloc_urbs()Pavel Roskin2007-07-15
| | | | | | It's done later, immediately before submission. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Eliminate priv->rx_urb, it shouldn't be therePavel Roskin2007-07-15
| | | | | | | | | | Pass the urb as data to the tasklet instead of priv. Remove some paranoid sanity checks in at76_rx_tasklet(). Rename at76_submit_rx_urb() to at76_submit_read_urb() to avoid confusion. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Make at76_dump_mib_mac_wep() more readablePavel Roskin2007-07-15
| | | | | | | It looked scary even considering that it was a purely debugging function. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Make at76_match_mode() more readablePavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Eliminate unneeded comma operatorPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove unused priv->ctrl_urb and priv->ctrl_bufferPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove rx_copybreak, act as if it's 0Pavel Roskin2007-07-15
| | | | | | | | | | | | | | | | | | | | | | | | | | | Remove a dubious optimization in the rx path. For short (shorter than rx_copybreak, 200 bytes by default) unfragmented packets, a new, shorter skb would be allocated, and the data would be copied into it, allowing the original skb to be recycled for another incoming packet. For a good memory allocator, allocating an skb of any size should not depend on the skb size as long at it remains shorter than a page. At least, the difference would be comparable to the price of copying the data. It's also likely that the newly allocated full-sized skb would actually use the memory left by consumption of the previous skb. Using variable size skbs could increase memory fragmentation and time to find another full-sized skb when it's finally needed. And last but not least, correctness and maintainability of the driver is more important than a marginal speed increase in the code, especially if no waiting for hardware is involved. Having two ways to do one thing increases complexity of the driver and the risk of breakage. Avoiding the optimization also allows to share more code between the fragmented and non-fragmented cases. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Use more definitions from net/ieee80211.h and linux/if_ether.hPavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Use __func__ in debug messagesPavel Roskin2007-07-15
| | | | | | | It's more standard than __FUNCTION__. Also fix some cases when the function name is hardcoded in the debug messages. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Comment changes for at76_init_new_device() and at76_init_new_device()Pavel Roskin2007-07-15
| | | | | | | | Remove an obsolete comment for at76_init_new_device(). There is no way it can be run before the firmware is loaded. Write better comments for at76_init_new_device() and at76_init_new_device(). Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Move usb_put_dev() further to the end of at76_delete_device()Pavel Roskin2007-07-15
| | | | | | | Make sure that the USB device won't be removed before all timers and scheduled works are canceled. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Expand request type macros in usb_control_msg() callsPavel Roskin2007-07-15
| | | | | | | They were used inconsistently. Besides, they don't make the code more readable. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Make firmware download utilities more uniformPavel Roskin2007-07-15
| | | | | | | Rename some functions and variables so that the internal and the external download don't look so different. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't use GFP_DMA, it's for ISA devicesPavel Roskin2007-07-15
| | | | | | | GFP_DMA forces allocation in the first 16M of memory, which is not needed. USB buffers should be using GFP_KERNEL. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Actually use onoff parameter in at76_set_iroaming()Pavel Roskin2007-07-15
| | | | | | | All callers already ensure that onoff is equal to priv->international_roaming, so the actual behavior is not affected. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Make it clear why we are adding 4 to buf->size in at76_set_mib()Pavel Roskin2007-07-15
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Give plain http URL for the firmware, not httpsPavel Roskin2007-07-15
| | | | | | | | The site certificate on developer.berlios.de is self-signed, which causes a browser warning. Plain http is just fine for publicly available firmware. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Convert skb compatibility code from functions to macrosPavel Roskin2007-07-15
| | | | | | | | | | | | One reason is that it can be expected that some vendor kernels will backport the Linux 2.6.22 skb API. Macros can safely mask the inline functions used by the vendor kernel, whereas inline functions will conflict and fail. Another reason is that linux/skbuff.h doesn't need to be included from compat.h anymore, which makes the compatibility code less intrusive. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Convert management timer/work to a delayed workPavel Roskin2007-06-26
| | | | | | | | | | | | This is likely not the final approch, as the code handles several different timeouts and may need to be split. Anyway, it would be easier to split a single delayed work than a timer and a work. When handling beacons, cancel the work first, as we want the timeout handler to be deferred. The delayed workqueue API doesn't seem to provide a nicer way to do it. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Rename get_hw_cfg_intersil() to at76_get_hw_cfg_intersil()Pavel Roskin2007-06-26
| | | | | | This function was missed earlier because it's always inlined. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Rename set_group_address to at76_set_group_address, clean it upPavel Roskin2007-06-26
| | | | | | | Although that function is commented out, it would be better to make it look like other functions. Remove "#if 1", it's confusing. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Rename functions ending with "matched" to start with "at76_match"Pavel Roskin2007-06-26
| | | | | | | It's more natural to use a common prefix, not suffix, for similar functions. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Don't print hex numbers starting with "x", use more common "0x"Pavel Roskin2007-06-26
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Re-examine and simplify code where "return" is followed by "else"Pavel Roskin2007-06-26
| | | | | | | | | | Try to make the code flow more linear. Handle easy cases early. This avoids unnecessary identation and a complex tree structure of the code. In at76_iw_handler_get_power(), an at76_dbg() call was supposed to cover the "disabled" case but would not actually be called. Fix it. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Avoid assignments inside conditions, they are hard to readPavel Roskin2007-06-26
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Implement 5 second timeout in at76_wait_completion()Pavel Roskin2007-06-26
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Remove unneeded parentheses when taking an addressPavel Roskin2007-06-26
| | | | | | | | It's uncommon to see them in the kernel. Dereferencing a pointer has priority over taking an address, and it's well known. Parentheses don't make the code more readable if it looks differently from other drivers. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Minor comment fixesPavel Roskin2007-06-26
| | | | | | | | | | | Avoid multi-line comments before functions if a single line comment is sufficient. Multi-line comments are better suited for larger blocks of code. Capitalize comments for functions. Remove some obsolete or wrong comments. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Replace a work/timer combination for restarts with a delayed workPavel Roskin2007-06-26
| | | | | | | | | | Decrease the delay to half second. It's enough to cover all requests from one iwconfig command, and improves the response time. Cancel the delayed work in at76_stop(). We don't need any restarts if the interface is down. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Fix recent breakage in at76_set_listen_interval()Pavel Roskin2007-06-26
| | | | | | An offset was substituted from a wrong macro. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Clean up code for internal firmware downloadPavel Roskin2007-06-16
| | | | | | | Use min() where needed. Expand DFU_USB_SUCCESS. Rename "result" and "status" to more traditional "ret". Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Eliminate struct dfu_ctxPavel Roskin2007-06-16
| | | | | | | There is no point in having that structure. Whatever was inside is allocated and used individually now. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Simplify at76_set_card_command()Pavel Roskin2007-06-16
| | | | | | | | Add "data" field to struct at76_command to avoid dubious code to access data beyound the end of structure. Don't make handle 0-byte buffer as a special case. Avoid extra indentation. Signed-off-by: Pavel Roskin <proski@gnu.org>
* [PATCH] Reuse at76_set_card_command() from at76_set_mib()Pavel Roskin2007-06-16
| | | | Signed-off-by: Pavel Roskin <proski@gnu.org>