aboutsummaryrefslogtreecommitdiff
path: root/at76_usb.h
Commit message (Expand)AuthorAge
* [PATCH] Bump version to 0.16HEADversion_0.16masterPavel Roskin2007-07-15
* [PATCH] Replace at76_assert with standard WARN_ON and BUG_ON macrosPavel Roskin2007-07-15
* [PATCH] Improve formatting of the headers, use tabs where possiblePavel Roskin2007-07-15
* [PATCH] Improve comments, reorder some fields in at76_usb.hPavel Roskin2007-07-15
* [PATCH] Remove priv->open_count, it's write-onlyPavel Roskin2007-07-15
* [PATCH] Eliminate priv->rx_urb, it shouldn't be therePavel Roskin2007-07-15
* [PATCH] Remove unused priv->ctrl_urb and priv->ctrl_bufferPavel Roskin2007-07-15
* [PATCH] Expand request type macros in usb_control_msg() callsPavel Roskin2007-07-15
* [PATCH] Convert management timer/work to a delayed workPavel Roskin2007-06-26
* [PATCH] Implement 5 second timeout in at76_wait_completion()Pavel Roskin2007-06-26
* [PATCH] Replace a work/timer combination for restarts with a delayed workPavel Roskin2007-06-26
* [PATCH] Simplify at76_set_card_command()Pavel Roskin2007-06-16
* [PATCH] Eliminate macros containing offsetof for MIB structuresPavel Roskin2007-06-16
* [PATCH] Add full support for "auto" preamblePavel Roskin2007-06-16
* [PATCH] Implement "get" counterparts for iwpriv callsPavel Roskin2007-06-16
* [PATCH] Improve info messages, avoid printing full pathPavel Roskin2007-06-14
* [PATCH] Save results of usb_sndbulkpipe() and usb_rcvbulkpipe()Pavel Roskin2007-06-14
* [PATCH] Simplify dumping hex dataPavel Roskin2007-06-14
* [PATCH] Don't use workqueue to reschedule IBSS creationPavel Roskin2007-06-14
* [PATCH] Don't keep priv->interface, use USB interface provided in at76_probe()Pavel Roskin2007-06-09
* [PATCH] Decouple networking from firmware downloadPavel Roskin2007-06-09
* [PATCH] Run at76_usb.h through LindentPavel Roskin2007-06-05
* [PATCH] Remove support for channel scanning in monitor modePavel Roskin2007-06-05
* [PATCH] Don't document endianess in comments, it's documented by the typePavel Roskin2007-06-05
* [PATCH] Rename request structures to make them distinct from functionsPavel Roskin2007-06-05
* [PATCH] Internal firmware download should just sleep without any timersPavel Roskin2007-06-03
* [PATCH] Don't reschedule firmware loadingPavel Roskin2007-06-03
* [PATCH] Rename tasklet to rx_tasklet, the former is too genericPavel Roskin2007-06-03
* [PATCH] Replace semaphores with mutexesPavel Roskin2007-05-02
* [PATCH] Call private data (at76_priv) "priv", not "dev", the later is ambiguousPavel Roskin2007-05-02
* [PATCH] Rename at76_get_fw_info() to at76_parse_fw(), fully rewritePavel Roskin2007-05-02
* move hw_rates, channel_frequency, snapsig and rfc1042 sig out of the header fileGuido Guenther2007-05-01
* [PATCH] Rename "site survey" to "scan", because it's a scan and nothing elsePavel Roskin2007-04-27
* [PATCH] Assorted minor comment changesPavel Roskin2007-04-27
* [PATCH] Split workqueues into separate handlersPavel Roskin2007-04-27
* [PATCH] Standardize on radiotap headers for monitor modePavel Roskin2007-04-17
* [PATCH] Remove nickname supportPavel Roskin2007-04-13
* [PATCH] Use safer declaration for at76_priv_handlersPavel Roskin2007-04-13
* [PATCH] Remove unused and write-only fields from some structuresPavel Roskin2007-04-13
* [PATCH] Change buffer pointers to void* or safer types to avoid castsPavel Roskin2007-04-13
* [PATCH] Move union of struct hwcfg_* to at76_usb.h, give it a namePavel Roskin2007-04-13
* rename dbg() to at76_dbg and assert() to at76_assert()Guido Guenther2007-04-02
* put functions and structures into the at76_ namespace, rename remaining AT76C...Guido Guenther2007-04-02
* cleanup PM code a bit:Guido Guenther2007-03-11
* dump_bss_table: get rid of useless force_output parameter and obuf_s in theGuido Guenther2007-03-11
* rename KEVENT_* to AT76_DEVENT, also rename the corresponding functions andGuido Guenther2007-03-10
* cleanup some comments and remove duplicate debug codeGuido Guenther2007-03-10
* use C99 array initializers for firmware namesGuido Guenther2007-03-10
* run through Lindent and merge in most of the hunksGuido Guenther2007-03-09
* [PATCH] Reuse more structures from Linux ieee80211 headersPavel Roskin2007-03-06