aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-02-14 17:44:39 +0100
committerGuido Günther <agx@sigxcpu.org>2016-02-14 17:44:39 +0100
commit4917bf2a6cb3dfe916ec9f6598a455c70b9a6f64 (patch)
tree7fa5c066264fe363d2d210d6db0003bf9eb12941 /setup.py
parent3c5933c961ee8c0777fb48afcee4d45a8a53e56c (diff)
Remove unused code
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 0 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index 1a1d9f3..f93a29e 100644
--- a/setup.py
+++ b/setup.py
@@ -22,32 +22,6 @@ import subprocess
from setuptools import setup, find_packages
import os
-
-def fetch_version():
- """Get version from debian changelog and write it to gbp/version.py"""
- version = "0.0"
-
- try:
- popen = subprocess.Popen('dpkg-parsechangelog', stdout=subprocess.PIPE)
- out, ret = popen.communicate()
- for line in out.decode('utf-8').split('\n'):
- if line.startswith('Version:'):
- version = line.split(' ')[1].strip()
- break
- except OSError:
- pass # Failing is fine, we just can't print the version then
-
- with open('gbp/version.py', 'w') as f:
- f.write('"The current gbp version number"\n')
- f.write('gbp_version="%s"\n' % version)
-
- return version
-
-
-def readme():
- with open('README') as file:
- return file.read()
-
setup(name = "foreman_ansible_inventory",
version = "0.0.1",
author = u'Guido Günther',