aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 12 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 1dbfc7e..4877532 100644
--- a/setup.py
+++ b/setup.py
@@ -18,21 +18,20 @@
#
# END OF COPYRIGHT #
-import subprocess
-from setuptools import setup, find_packages
-import os
+from setuptools import setup
-setup(name = "foreman_ansible_inventory",
- version = "0.0.3",
- author = u'Guido Günther',
- author_email = 'agx@sigxcpu.org',
- description = 'Ansible dynamic inventory that queries the Foreman',
- license = 'GPLv3+',
- classifiers = [
+setup(name="foreman_ansible_inventory",
+ version="0.0.3",
+ author=u'Guido Günther',
+ author_email='agx@sigxcpu.org',
+ description='Ansible dynamic inventory that queries the Foreman',
+ license='GPLv3+',
+ classifiers=[
'Environment :: Console',
'Programming Language :: Python :: 2',
'Operating System :: POSIX :: Linux',
],
- scripts = ['foreman_ansible_inventory.py'],
- requires = ["requests"],
-)
+ scripts=['foreman_ansible_inventory.py'],
+ requires=["requests"],
+ tests_require=['responses'],
+ )