summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-10-05 19:31:52 +0200
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-10-05 19:31:52 +0200
commit7f1faea64d42f069386352135a696b18aa6b4d5d (patch)
treed4a1e43098263fc982b2aee6a5a6920b56f4fd03
parent631156b0ec1ef1bfcfd90bf5a6baf888cd4e4d5f (diff)
also filter out git metadata when building tarballs
not only when building diffs (affects Debian native packages)
-rw-r--r--debian/changelog4
-rwxr-xr-xgit-buildpackage2
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 76986029..84c5c715 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,10 @@ git-buildpackage (0.2.6) git-buildpackage; urgency=low
* UNRELEASED
* run pychecker during build
+ * also filter out git metadata when building tarballs, not only when
+ building diffs (affects Debian native packages)
- -- Guido Guenther <agx@sigxcpu.org> Thu, 5 Oct 2006 19:13:34 +0200
+ -- Guido Guenther <agx@sigxcpu.org> Thu, 5 Oct 2006 19:30:00 +0200
git-buildpackage (0.2.5) git-buildpackage; urgency=low
diff --git a/git-buildpackage b/git-buildpackage
index d09317e0..5645b54d 100755
--- a/git-buildpackage
+++ b/git-buildpackage
@@ -62,7 +62,7 @@ def main(argv):
print >>sys.stderr, out
print >>sys.stderr, "Use --git-ignore_new to ignore."
return 1
- Command(options.build_cmd,['-i.git']+dpkg_args)()
+ Command(options.build_cmd,[ '-i.git', '-I.git' ]+dpkg_args)()
if options.tag:
version=get_version()
if version: