summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-10-05 19:14:49 +0200
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-10-05 19:14:49 +0200
commit631156b0ec1ef1bfcfd90bf5a6baf888cd4e4d5f (patch)
tree544eb5abf1395da35d5b12f3212bd129dbf69da2
parentad8bb760db4cb787793e78b86f40bd6e699b7c49 (diff)
run pychecker during build
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules10
3 files changed, 16 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index fa2d0849..76986029 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+git-buildpackage (0.2.6) git-buildpackage; urgency=low
+
+ * UNRELEASED
+ * run pychecker during build
+
+ -- Guido Guenther <agx@sigxcpu.org> Thu, 5 Oct 2006 19:13:34 +0200
+
git-buildpackage (0.2.5) git-buildpackage; urgency=low
* fix syntax error in tag replacement
diff --git a/debian/control b/debian/control
index 4a99d00c..c07f0e65 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: git-buildpackage
Section: devel
Priority: optional
Maintainer: Guido Guenther <agx@sigxcpu.org>
-Build-Depends: cdbs, debhelper (>= 5), python-dev, python-support (>= 0.3), docbook-to-man
+Build-Depends: cdbs, debhelper (>= 5), python-dev, python-support (>= 0.3), docbook-to-man, pychecker
Standards-Version: 3.7.2
Package: git-buildpackage
diff --git a/debian/rules b/debian/rules
index aecd46bc..47c6c942 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,11 +9,17 @@ include /usr/share/cdbs/1/class/python-distutils.mk
COMMANDS=git-buildpackage git-import-dsc git-import-orig
MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS))
+PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
+PYCHECK_LEVEL=Error
docs/%.1: docs/%.sgml
docbook-to-man $< > $@
-build/git-buildpackage:: $(MANPAGES)
+%.py: %
+ ln -s $< $@
+ PYTHONPATH=. pychecker -e $(PYCHECK_LEVEL) -q $<
+
+build/git-buildpackage:: $(MANPAGES) $(PYCHECKS)
clean::
- -rm docs/*.1 docs/manpage.*
+ -rm docs/*.1 docs/manpage.* git-*.py