aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-09-12 15:08:19 +0200
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-09-12 15:08:19 +0200
commit6ffbf26bfa0b4b6c62daaf8ae65a293a398342f1 (patch)
tree3db2530c4f27559527fa9de4198ccde90e27c2e1
parentd4d6d38ad6c90b19664ec7a6a9f89bf6753e82cf (diff)
add debian packaging
-rw-r--r--README3
-rw-r--r--debian/README.Debian6
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control17
-rw-r--r--debian/copyright22
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs1
-rw-r--r--debian/pycompat1
-rw-r--r--debian/pyversions1
-rwxr-xr-xdebian/rules11
-rwxr-xr-xgit-debuild16
-rwxr-xr-xgit-import-dsc18
-rw-r--r--setup.py26
14 files changed, 126 insertions, 5 deletions
diff --git a/README b/README
index d46d0686..4c3eebea 100644
--- a/README
+++ b/README
@@ -8,3 +8,6 @@ This is a bunch of scripts to ease the development of Debian packages with git:
Usage: git-debuild [--git-ignore-new] [-git-tag]
--git-ignore-new: ignore uncommited changes
--git-tag: tag after building (version number is fetched from the changelog)
+
+To import new upstream sources you can use tla-load-dirs from Debian with this patch:
+ http://honk.sigxcpu.org/unsorted-patches/tla-load-dir_git-support.diff
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 00000000..77d5ffec
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,6 @@
+git-buildpackage for Debian
+---------------------------
+
+<possible notes regarding this package - if none, delete this file>
+
+ -- Guido Guenther <agx@sigxcpu.org>, Tue, 12 Sep 2006 14:55:57 +0200
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..ce31a69a
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+git-buildpackage (0.01) unstable; urgency=low
+
+ * Initial release
+
+ -- Guido Guenther <agx@sigxcpu.org> Tue, 12 Sep 2006 14:55:57 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..7ed6ff82
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..5112ab46
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,17 @@
+Source: git-buildpackage
+Section: devel
+Priority: optional
+Maintainer: Guido Guenther <agx@sigxcpu.org>
+Build-Depends: cdbs, debhelper (>= 5), python-dev, python-support (>= 0.3)
+Standards-Version: 3.7.2
+
+Package: git-buildpackage
+Architecture: all
+Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, devscripts
+Suggests: git-load-dirs
+Description: bunch of scripts to ease the development of Debian packages with git
+ This package contains the following tools:
+ * git-import-dsc: import an existing Debian source package into a git
+ repository
+ * git-debuild: build a package out of a git repository, check for local
+ modifications and tag appropriately
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..6e2a6ac7
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,22 @@
+This package was debianized by Guido Guenther <agx@sigxcpu.org> on
+Tue, 12 Sep 2006 14:55:57 +0200.
+
+It was downloaded from <fill in http/ftp site>
+
+Upstream Author: <put author(s) name and email here>
+
+Copyright: <put the year(s) of the copyright, and the names of the
+ copyright holder(s) here>
+
+License:
+
+<Put the license of the package here>
+
+
+The Debian packaging is (C) 2006, Guido Guenther <agx@sigxcpu.org> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
+
+
+# Please also look if there are files or directories which have a
+# different copyright/license attached and list them here.
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 00000000..ca882bbb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 00000000..e845566c
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/pycompat b/debian/pycompat
new file mode 100644
index 00000000..0cfbf088
--- /dev/null
+++ b/debian/pycompat
@@ -0,0 +1 @@
+2
diff --git a/debian/pyversions b/debian/pyversions
new file mode 100644
index 00000000..6b4950e3
--- /dev/null
+++ b/debian/pyversions
@@ -0,0 +1 @@
+2.4
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..94643696
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+DEB_TAR_SRCDIR := python-dateutil
+DEB_AUTO_CLEANUP_RCS := yes
+
+DEB_PYTHON_SYSTEM = pysupport
+DEB_PYTHON_CLEAN_ARGS = --all
+
+# Add here any variable or target overrides you need
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
diff --git a/git-debuild b/git-debuild
index 712c8b00..274fa1b9 100755
--- a/git-debuild
+++ b/git-debuild
@@ -2,8 +2,20 @@
#
# run debuild in a git repository
#
-# (c) 2006 Guido Guenther <agx@sigxcpu.org>
-# License: GPLv2
+# (C) 2006 Guido Guenther <agx@sigxcpu.org>
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
import sys,os,commands,re
import optparse
diff --git a/git-import-dsc b/git-import-dsc
index e4b4c9aa..ee074f19 100755
--- a/git-import-dsc
+++ b/git-import-dsc
@@ -1,13 +1,25 @@
#!/usr/bin/python
#
# make a git archive out of a Debian source package
-
-# (c) 2006 Guido Guenther <agx@sigxcpu.org>
-# License: GPLv2
#
# FIXME: - error handling
# - better use 'dpkg-source -x'
# - import debian native packages
+#
+# (C) 2006 Guido Guenther <agx@sigxcpu.org>
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
import sys,re,os,tempfile,glob
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..7b6f8753
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python2.3
+# Copyright (C) 2006 Guido Guenther <agx@sigxcpu.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# END OF COPYRIGHT #
+
+from distutils.core import setup
+
+setup(name = "git_build_package",
+ author = 'Guido Guenther',
+ author_email = 'agx@sigxcpu.org',
+ scripts = ['git-import-dsc', 'git-debuild']
+)
+