summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2008-06-20 09:15:27 +0200
committerGuido Guenther <agx@sigxcpu.org>2008-06-20 09:15:27 +0200
commit26c0310d023fc051583b703bb3f08409b409b4c9 (patch)
tree5d84e44f5e8b1572ff9039d040acced801f391e6
parente6ce2dff1e41477cc7311fa1de83bb10c57467d1 (diff)
make no-dch configurable via gbp.conf
-rw-r--r--gbp/config.py1
-rwxr-xr-xgit-import-orig6
2 files changed, 4 insertions, 3 deletions
diff --git a/gbp/config.py b/gbp/config.py
index 8f672e92..b9948aca 100644
--- a/gbp/config.py
+++ b/gbp/config.py
@@ -42,6 +42,7 @@ class GbpOptionParser(OptionParser):
'ignore-new' : 'False',
'meta' : 'False',
'id-length' : '0',
+ 'no-dch' : 'False',
}
config_files = [ '/etc/git-buildpackage/gbp.conf',
os.path.expanduser('~/.gbp.conf'),
diff --git a/git-import-orig b/git-import-orig
index 0bc43f73..22af1008 100755
--- a/git-import-orig
+++ b/git-import-orig
@@ -102,8 +102,8 @@ def main(argv):
help="verbose command execution")
parser.add_option("--no-merge", dest='merge', action="store_false", default=True,
help="after import dont do any merging to another branch")
- parser.add_option("--no-dch", dest='run_dch', action="store_false", default=True,
- help="don't call dch after the import")
+ parser.add_config_file_option(option_name="no-dch", dest='no_dch',
+ help="don't call dch after the import", action="store_true")
parser.add_config_file_option(option_name="debian-branch", dest='debian_branch',
help="branch the debian patch is being developed on, default is '%(debian-branch)s'")
parser.add_config_file_option(option_name="upstream-branch", dest="upstream_branch",
@@ -219,7 +219,7 @@ on howto create it otherwise use --upstream-branch to specify it.
gitPullUpstream()
except gbpc.CommandExecFailed:
raise GbpError, """Merge failed, please resolve and run "dch -v %s-1".""" % version
- if options.run_dch:
+ if not options.no_dch:
epoch = ''
if os.access('debian/changelog', os.R_OK):
cp = parse_changelog('debian/changelog')