summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2008-05-17 19:40:00 +0200
committerGuido Guenther <agx@sigxcpu.org>2008-05-17 19:40:00 +0200
commit3f873eb65ff37b721d468edc88782a91c470117f (patch)
tree4a7967232156af2b9a0ae8f3066de8f32e7d53dd
parent2cfbf050329b52971e5390ec6ef6416bcbc3d67e (diff)
add a version property
-rw-r--r--debian/changelog11
-rw-r--r--gbp/deb_utils.py11
2 files changed, 22 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4467dbbc..10b41db0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+git-buildpackage (0.4.29~1.gbpce152d) UNRELEASED; urgency=low
+
+ ** SNAPSHOT build @ce152d4078c0fc93845865cadda816c7c9ebabe4 **
+
+ * UNRELEASED
+ * [ce152d4] git-dch: include the commit id in the changelog entry
+ * [ad6ff99] git-dch: print default value of --meta
+ * [2c1c265] git-dch: avoid extra space before "(Closes: )"
+
+ -- Guido Guenther <agx@sigxcpu.org> Fri, 16 May 2008 14:25:40 +0200
+
git-buildpackage (0.4.28) unstable; urgency=low
* git-buildpackage: add --git-dont-purge to leave the exported build dir
diff --git a/gbp/deb_utils.py b/gbp/deb_utils.py
index d2886467..4d764156 100644
--- a/gbp/deb_utils.py
+++ b/gbp/deb_utils.py
@@ -68,6 +68,17 @@ class DscFile(object):
elif not self.tgz:
raise GbpError, "Cannot parse archive name from %s" % self.dscfile
+ def _get_version(self):
+ if self.native:
+ return self.upstream_version
+ else:
+ return "%s-%s" % (self.upstream_version, self.debian_version)
+
+ version = property(_get_version)
+
+ def __str__(self):
+ return "<%s object %s>" % (self.__class__.__name__, self.dscfile)
+
def parse_dsc(dscfile):
"""parse dsc by creating a DscFile object"""