summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2007-10-19 08:40:20 +0200
committerGuido Guenther <agx@sigxcpu.org>2007-10-19 08:40:20 +0200
commit51a48acd6809c2dc921e68c618b61aa5ae66925b (patch)
tree6bca73222fd6ddba8a3b352ec481968655f4a48b
parent6aba358c925dd3c29db23cbd2123bdcb5950ab70 (diff)
don't split up the manual that much (local.dsl taken from darcs-buildpackage)
-rwxr-xr-xdebian/rules2
-rw-r--r--docs/local.dsl34
2 files changed, 35 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c20b9efa..1dc87692 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,7 @@ docs/%.1: docs/man.%.sgml
docbook2man -o docs/ $<
$(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
- docbook-2-html -s gtk $<
+ docbook-2-html -s local $<
%.py: %
ln -s $< $@
diff --git a/docs/local.dsl b/docs/local.dsl
new file mode 100644
index 00000000..a9a6d052
--- /dev/null
+++ b/docs/local.dsl
@@ -0,0 +1,34 @@
+<!DOCTYPE style-sheet PUBLIC "-//James Clark//DTD DSSSL Style Sheet//EN" [
+<!ENTITY dbstyle PUBLIC "-//GtkViaAlcove//DOCUMENT Gtk-doc HTML Stylesheet//EN" CDATA DSSSL>
+]>
+
+<style-sheet>
+<style-specification use="gtk">
+<style-specification-body>
+
+;; Don't split up the doc as much.
+(define (chunk-element-list)
+ (list (normalize "preface")
+ (normalize "chapter")
+ (normalize "appendix")
+ (normalize "article")
+ (normalize "glossary")
+ (normalize "bibliography")
+ (normalize "index")
+ (normalize "colophon")
+ (normalize "setindex")
+ (normalize "reference")
+ (normalize "refentry")
+ (normalize "part")
+ (normalize "book") ;; just in case nothing else matches...
+ (normalize "set") ;; sets are definitely chunks...
+ ))
+
+</style-specification-body>
+</style-specification>
+<external-specification id="gtk" document="dbstyle">
+</style-sheet>
+
+<!--
+# arch-tag: web stylesheet for documentation
+-->