summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2009-08-22 13:54:34 +0200
committerGuido Günther <agx@sigxcpu.org>2009-08-22 13:54:34 +0200
commit4f82dfb563926b7a145e093471b7ccedcae39145 (patch)
tree17c687863f401828a5d91a296067c384e7e633b5
parentd42ed408802bf6d894e12322b6d1effcbde68e4c (diff)
honor DEB_BUILD_OPTIONS=nocheck
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ed34eca4..057bf73f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,6 @@
DEB_PYTHON_SYSTEM = pysupport
DEB_PYTHON_CLEAN_ARGS = --all
-# Add here any variable or target overrides you need
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
@@ -24,6 +23,10 @@ $(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
docbook-2-html -s local $<
cp /usr/share/gtk-doc/data/*.png $(MANUAL)
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+checks: $(PYCHECKS)
+endif
+
%.py: %
ln -s $< $@
PYTHONPATH=. pychecker -e $(PYCHECK_LEVEL) -q $<
@@ -34,10 +37,11 @@ $(GBP_VERSION): debian/changelog
$(VERSION_ENT): debian/changelog
echo '<!ENTITY gbp-version "$(DEB_VERSION)">' > $(VERSION_ENT)
-build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(GBP_VERSION) $(PYCHECKS)
+build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(GBP_VERSION) checks
clean::
-rm git-*.py
-rm docs/*.1 docs/manpage.* $(VERSION_ENT)
-rm -r docs/manual-html/
+.PHONY: checks