summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-08-12 18:37:06 +0200
committerGuido Günther <agx@sigxcpu.org>2010-08-12 18:37:44 +0200
commit76b16df48a351cf7b8a895bdbcd09e2b8b873b08 (patch)
treef946cffd8af1d75556b8ee3fb0f9e390965a84ec
parent61e0c3c9f9dda6f448b0a80175cbf54fdc966d94 (diff)
Build and install git-pbuilder manpage
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules7
2 files changed, 7 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index c9a63cab..42e00f4d 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Guido Günther <agx@sigxcpu.org>
Build-Depends: cdbs, debhelper (>= 5), python, python-support (>= 0.3),
pychecker, gtk-doc-tools, sgml2x, docbook-utils, jade, python-dateutil, python-nose,
- bash-completion
+ bash-completion, perl
Standards-Version: 3.9.1
Vcs-Git: git://honk.sigxcpu.org/git/git-buildpackage.git
Vcs-Browser: http://git.debian.org/?p=users/agx/git-buildpackage.git
diff --git a/debian/rules b/debian/rules
index 8a1d813a..b81ad946 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,9 @@ EXAMPLE_SCRIPTS=\
DEB_COMPRESS_EXCLUDE=$(EXAMPLE_SCRIPTS)
-MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS) gbp-pq)
+SGML_MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS) gbp-pq)
+POD_MANPAGES=docs/git-pbuilder.1
+MANPAGES=$(SGML_MANPAGES) $(POD_MANPAGES)
MANUAL=docs/manual-html
PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
PYCHECK_LEVEL=Error
@@ -39,6 +41,9 @@ $(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
docbook-2-html -s local $<
cp /usr/share/gtk-doc/data/*.png $(MANUAL)
+docs/git-pbuilder.1: git-pbuilder
+ pod2man $< $@
+
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
checks: $(PYCHECKS)
nosetests --with-doctest