summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorMarkus Lehtonen <markus.lehtonen@linux.intel.com>2018-01-17 13:35:10 +0200
committerGuido Günther <agx@sigxcpu.org>2018-01-18 11:09:21 +0100
commit5e9ab951b69830d265e7daac1471325a532314a9 (patch)
treec3b67c38d391037a0baed09ad9f984b3b4c51f4b
parent832638188789a94a4b6fe146e87c4c2998a53a12 (diff)
docs: dynamically select the DocBook-to-man tool to use
Different distributions use different name for the DocBook-to-man converter tool, so, try to dynamically guess the correct name of the tool. Signed-off-by: Markus Lehtonen <markus.lehtonen@linux.intel.com>
-rw-r--r--docs/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/docs/Makefile b/docs/Makefile
index e6e94c2c..b7258a47 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -38,6 +38,13 @@ MAN_DATE=$(shell dpkg-parsechangelog -l ../debian/changelog -SDate | TZ=UTC LC_A
IMAGES=$(wildcard images/*png)
DEST_IMAGES=$(subst images/,$(MANUAL)/images/,$(IMAGES))
+# Select docbook-to-man tool
+ifeq ($(shell which docbook2x-man), )
+ DOCBOOK_TO_MAN=docbook-to-man
+else
+ DOCBOOK_TO_MAN=docbook2x-man
+endif
+
all: manual $(MANPAGES)
manual: $(MANUAL)/index.html $(DEST_IMAGES) css
@@ -62,7 +69,7 @@ $(MANUAL)/images/%.png: images/%.png
install $< $@
%.1 %.5: man.gbp.xml manpages/%.xml
- docbook2x-man -o . $<
+ $(DOCBOOK_TO_MAN) -o . $<
git-pbuilder.1: ../bin/git-pbuilder
pod2man $< $@