summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-12-21 15:21:43 +0100
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-12-21 15:21:43 +0100
commit69e776a291872d0b20f5a55527b68ea09996b920 (patch)
treee82cc22292689a0ea021cf073235c0885daff85c
parent06e6289f643a7c71956b36d5cd253d2e86c9f292 (diff)
git-buildpackage: add an option (--git-cleaner) that allows to specify a different clean command (Closes: #403987)debian/0.2.19
-rw-r--r--debian/changelog7
-rw-r--r--docs/manpages/git-buildpackage.sgml7
-rwxr-xr-xgit-buildpackage4
-rw-r--r--git_buildpackage/config.py10
4 files changed, 20 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 1ead3d9b..280f333f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,12 @@
-git-buildpackage (0.2.19) experimental; urgency=low
+git-buildpackage (0.2.19) unstable; urgency=low
- * UNRELEASED
+ * git-buildpackage: add an option (--git-cleaner) that allows to specify
+ a different clean command (Closes: #403987)
* depend on a git-core that has git-archive
* s/keyid/GPG keyid/
* minor fixes all over the place
- -- Guido Guenther <agx@sigxcpu.org> Wed, 13 Dec 2006 22:39:42 +0100
+ -- Guido Guenther <agx@sigxcpu.org> Thu, 21 Dec 2006 15:18:40 +0100
git-buildpackage (0.2.18) experimental; urgency=low
diff --git a/docs/manpages/git-buildpackage.sgml b/docs/manpages/git-buildpackage.sgml
index bf473af3..70c1dfda 100644
--- a/docs/manpages/git-buildpackage.sgml
+++ b/docs/manpages/git-buildpackage.sgml
@@ -30,6 +30,7 @@
<arg><option>--upstream-branch=<replaceable>branch_name</replaceable></option></arg>
<arg><option>--debian-branch=<replaceable>branch_name</replaceable></option></arg>
<arg><option>--git-builder=<replaceable>BUILD_CMD</replaceable></option></arg>
+ <arg><option>--git-cleaner=<replaceable>CLEAN_CMD</replaceable></option></arg>
<arg><option>--git-sign-tags</option></arg>
<arg><option>--git-keyid</option></arg>
</cmdsynopsis>
@@ -89,6 +90,12 @@
</listitem>
</varlistentry>
<varlistentry>
+ <term><option>--git-cleaner=<replaceable>CLEAN_CMD</replaceable></option></term>
+ <listitem>
+ <para>Use <replaceable>CLEAN_CMD</replaceable> instead of <command>debuild clean</command></para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
<term><option>--git-verbose</option>
</term>
<listitem>
diff --git a/git-buildpackage b/git-buildpackage
index 95a9491c..95d7216d 100755
--- a/git-buildpackage
+++ b/git-buildpackage
@@ -63,6 +63,8 @@ def main(argv):
help="verbose command execution")
parser.add_config_file_option(option_name="builder", dest="build_cmd",
help="command to build the package e.g. default is '%(builder)s'")
+ parser.add_config_file_option(option_name="cleaner", dest="clean_cmd",
+ help="command to build the package e.g. default is '%(cleaner)s'")
parser.add_config_file_option(option_name="upstream-branch", dest="upstream_branch",
help="upstream branch, default is '%(upstream-branch)s'")
parser.add_config_file_option(option_name="debian-branch", dest='debian_branch',
@@ -82,7 +84,7 @@ def main(argv):
try:
if not options.ignore_new:
- Command(options.build_cmd, ['clean'])()
+ Command(options.clean_cmd)()
(ret, out) = is_repository_clean('.')
if not ret:
print >>sys.stderr, "You have uncommitted changes in your source tree:"
diff --git a/git_buildpackage/config.py b/git_buildpackage/config.py
index e1fde158..cff42553 100644
--- a/git_buildpackage/config.py
+++ b/git_buildpackage/config.py
@@ -23,11 +23,12 @@ class GBPOptionParser(OptionParser):
@type config_files: list
"""
defaults={ 'builder' : 'debuild',
+ 'cleaner' : 'debuild clean',
'debian-branch' : 'master',
'upstream-branch' : 'upstream',
'upstream-branch' : 'upstream',
- 'sign-tags' : '', # empty means False
- 'keyid' : '',
+ 'sign-tags' : '', # empty means False
+ 'keyid' : '',
}
config_files=['/etc/git-buildpackage/gbp.conf',
os.path.expanduser('~/.gbp.conf'),
@@ -59,6 +60,7 @@ class GBPOptionParser(OptionParser):
@type help: string
"""
OptionParser.add_option(self,"--%s%s" % (self.prefix, option_name), dest=dest,
- default=self.config[option_name],
- help=help % self.config, **kwargs)
+ default=self.config[option_name],
+ help=help % self.config, **kwargs)
+# vim:et:ts=4:sw=4: