summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2007-02-02 16:27:18 +0100
committerGuido Guenther <agx@bogon.sigxcpu.org>2007-02-02 16:27:18 +0100
commit9288730ff4e24639a455db5d963ca6ec09ca39c3 (patch)
treebd5a1dfc41cf03fa7d435584ccc3a4c82fb8b592
parentc5f8b9855f593a28ebf40a411ba65bca588e247a (diff)
document changesdebian/0.2.25
-rw-r--r--debian/NEWS6
-rw-r--r--debian/changelog21
-rw-r--r--debian/examples1
-rwxr-xr-xexamples/git-pbuilder8
4 files changed, 28 insertions, 8 deletions
diff --git a/debian/NEWS b/debian/NEWS
new file mode 100644
index 00000000..7eeace09
--- /dev/null
+++ b/debian/NEWS
@@ -0,0 +1,6 @@
+git-buildpackage (0.2.25) unstable; urgency=low
+
+ Generated tags are now by default put into debian/ and upstream/ namespaces.
+ This doesn't have any effect on already existing tags.
+
+ -- Guido Guenther <agx@sigxcpu.org> Fri, 2 Feb 2007 15:56:12 +0100
diff --git a/debian/changelog b/debian/changelog
index 401e2696..e94c00ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,19 @@
git-buildpackage (0.2.25) unstable; urgency=low
- * UNRELEASED
- * posttag suport for git-buildpackage: use --git-posttag to run a command
- after a successfull build with tag (e.g. --git-posttag='git-push --tags
+ * posttag support for git-buildpackage: use --git-posttag to run a command
+ after a successfull build and tag (e.g. --git-posttag='git-push --tags
git.alioth.org')
- * Repositories that never had the upstream sources as a single commit can be
- made git-import-orig compatible by using git's grafts. Mention this in the
- manual (Closes: #403988).
-
- -- Guido Guenther <agx@sigxcpu.org> Thu, 1 Feb 2007 17:54:56 +0100
+ * repositories that weren't created by git-import-dsc and never had the
+ upstream sources as a single commit (let alone an upstream branch) can be
+ made git-import-orig compatible by using git's grafts - mention this in
+ the manual. This (Closes: #403988) since with this every git repo can use
+ git-import-orig (with some preparation).
+ * Allow to specify the tag format. The format of generated tags can now be
+ specified via the debian-tag and upsteam-tag options. The default now puts
+ debian tags and upstream tags into different namespaces (Closes: #408990).
+ * add example for pbuilder
+
+ -- Guido Guenther <agx@sigxcpu.org> Fri, 2 Feb 2007 16:26:52 +0100
git-buildpackage (0.2.24) unstable; urgency=low
diff --git a/debian/examples b/debian/examples
new file mode 100644
index 00000000..e39721e2
--- /dev/null
+++ b/debian/examples
@@ -0,0 +1 @@
+examples/*
diff --git a/examples/git-pbuilder b/examples/git-pbuilder
new file mode 100755
index 00000000..d8e62e3d
--- /dev/null
+++ b/examples/git-pbuilder
@@ -0,0 +1,8 @@
+#!/bin/sh -e
+#
+# pbuilder helper for git-buildpackage
+# use this as "builder" in gbp.conf
+
+# pass all options to dpkg-buildpackage:
+pdebuild --debbuildopts "$*"
+