summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2017-11-27 19:59:32 +0100
committerGuido Günther <agx@sigxcpu.org>2017-11-27 22:49:52 +0100
commita12c5960232fc10996324d3204bd468cb80ec76b (patch)
tree6a5391c3e11bc8b2439ada78686427dedce78d5c
parente96ae7b4dcea85a9230a8889e2f3affb06207bf1 (diff)
DebianSource: document toplevel requirement
Gbp-Dch: Ignore
-rw-r--r--gbp/deb/source.py4
-rw-r--r--tests/15_test_DebianSource.py2
2 files changed, 3 insertions, 3 deletions
diff --git a/gbp/deb/source.py b/gbp/deb/source.py
index 78a1c93b..643aac2e 100644
--- a/gbp/deb/source.py
+++ b/gbp/deb/source.py
@@ -51,7 +51,9 @@ class DebianSource(object):
def __init__(self, vfs):
"""
@param vfs: a class that implemented GbpVFS interface or
- a directory (which will use the I{FileVFS} class.
+ a directory (which will use the I{FileVFS} class. The
+ directory must be the toplevel of a Debian source
+ package.
"""
self._changelog = None
diff --git a/tests/15_test_DebianSource.py b/tests/15_test_DebianSource.py
index f7f333b6..efc38b4f 100644
--- a/tests/15_test_DebianSource.py
+++ b/tests/15_test_DebianSource.py
@@ -86,7 +86,6 @@ class TestDebianSource(testutils.DebianGitTestRepo):
self.assertFalse(source.is_native())
def test_is_releasable(self):
- source = DebianSource('.')
os.makedirs('debian/')
with open('debian/changelog', 'w') as f:
f.write("""git-buildpackage (0.2.3) unstable; urgency=low
@@ -100,7 +99,6 @@ class TestDebianSource(testutils.DebianGitTestRepo):
self.assertTrue(source.is_releasable())
def test_is_not_releasable(self):
- source = DebianSource('.')
os.makedirs('debian/')
with open('debian/changelog', 'w') as f:
f.write("""git-buildpackage (0.2.3) UNRELEASED; urgency=low