summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-02-20 17:18:05 +0100
committerGuido Günther <agx@sigxcpu.org>2015-02-20 18:47:30 +0100
commita2a37ea2f99152c70ee4386b30ed280831aee150 (patch)
treea9b7707682c8540dbaae3b68ecb4e0ce7f6cae8b
parentce03d4f27a474e3f7ede0bdbcd25081cf963e1c8 (diff)
Don't output additional newlines
introduced by 0a4725c045a5a55592dafd41c6ef6f9bab4791cd
-rw-r--r--gbp/deb/changelog.py2
-rw-r--r--tests/test_Changelog.py2
2 files changed, 3 insertions, 1 deletions
diff --git a/gbp/deb/changelog.py b/gbp/deb/changelog.py
index a483b339..1866368f 100644
--- a/gbp/deb/changelog.py
+++ b/gbp/deb/changelog.py
@@ -272,7 +272,7 @@ class ChangeLog(object):
for line in msg[1:]:
print(" " + line, file=new_cl)
else:
- print(line, file=new_cl)
+ print(line, end='', file=new_cl)
os.rename("debian/changelog.bak", "debian/changelog")
def add_entry(self, msg, author=None, email=None, dch_options=[]):
diff --git a/tests/test_Changelog.py b/tests/test_Changelog.py
index 8f807ee2..a22731f1 100644
--- a/tests/test_Changelog.py
+++ b/tests/test_Changelog.py
@@ -302,6 +302,8 @@ def test_add_entry():
True
>>> 'Test add entry' in cl['Changes']
True
+ >>> cl['Changes'].split('*',1)[1]
+ ' Test add section\\n * Test add entry'
>>> os.chdir(olddir)
>>> os.path.abspath(os.path.curdir) == olddir
True