summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2010-05-04 08:58:57 +0200
committerGuido Günther <agx@sigxcpu.org>2010-05-04 08:58:57 +0200
commita2dd58d8a72f05f7cbe2e041fd1a75242ec107d8 (patch)
tree26712ed8bc2111d3099ff00d2892c65d90ff88e6
parentcc4647d9b5d30d2a74e15d358b18a7db6b4cac25 (diff)
Requests for non fast-forward updates should exit with a non-zero result
Closes: #579997
-rwxr-xr-xgbp-pull5
1 files changed, 4 insertions, 1 deletions
diff --git a/gbp-pull b/gbp-pull
index 0352d7c0..71f6c0bf 100755
--- a/gbp-pull
+++ b/gbp-pull
@@ -40,9 +40,11 @@ def fast_forward_branch(branch, repo, options):
fast_forward = True
else:
print >>sys.stderr, "Warning: Skipping non-fast forward of '%s' - use --force" % branch
+
if fast_forward:
repo.set_branch(branch)
GitMerge(remote)()
+ return fast_forward
def main(argv):
changelog = 'debian/changelog'
@@ -92,7 +94,8 @@ def main(argv):
GitFetch()()
for branch in branches:
- fast_forward_branch(branch, repo, options)
+ if not fast_forward_branch(branch, repo, options):
+ retval = 2
if options.redo_pq:
repo.set_branch(options.debian_branch)