summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2008-01-10 14:19:33 +0100
committerGuido Guenther <agx@sigxcpu.org>2008-01-10 14:19:33 +0100
commitb45ee8ac68148cf6b3d270fb8d7e75b41e3bd881 (patch)
tree8b5f729eda6e85679d1f278cea2740e6fca474d2
parent4a1869ad3e27f70599b368f3912a95a4f396e5e8 (diff)
parenteb00b2cf3daf31e4faa60dbeea3bc066d905f363 (diff)
Merge branch 'master' into bpo-etch
Conflicts: debian/changelog
-rw-r--r--debian/changelog36
-rw-r--r--debian/control3
-rw-r--r--debian/dirs2
-rw-r--r--debian/doc-base11
-rw-r--r--docs/chapters/building.sgml16
-rw-r--r--gbp/git_utils.py8
-rwxr-xr-xgit-dch4
-rwxr-xr-xgit-import-dsc5
-rwxr-xr-xgit-import-orig4
9 files changed, 70 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 6c6d8d40..aaecdbf2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,39 @@
+git-buildpackage (0.4.13) unstable; urgency=low
+
+ * git-import-orig: don't fail when importing into empty git archives
+
+ -- Guido Guenther <agx@sigxcpu.org> Fri, 28 Dec 2007 23:01:29 +0100
+
+git-buildpackage (0.4.12) unstable; urgency=low
+
+ * remove unused debian/dirs
+ * bump standards version
+ * add a homepage field
+ * add doc-base file (Closes: #457495)
+ * git-import-orig: fix doc url (Closes: #456535)
+ * use export-dir instead of build-area in gbp.conf because git-
+ buildpackage has no --git-build-area option - thanks to Frank S. Thomas
+ for the patch.
+
+ -- Guido Guenther <agx@sigxcpu.org> Sun, 23 Dec 2007 20:35:45 +0100
+
+git-buildpackage (0.4.11) unstable; urgency=low
+
+ * --export-dir and --export are actually --git-export-dir and --git-
+ export (Closes: #456384) - thanks to Frank S. Thomas for the patch.
+ * don't start a new changelog section if we found a snapshot header
+ even when distribution != UNRELEASED
+
+ -- Guido Guenther <agx@sigxcpu.org> Sat, 15 Dec 2007 17:16:34 +0100
+
+git-buildpackage (0.4.10) unstable; urgency=low
+
+ * git-ls-files: separate filenames by '\0', based on a patch from Uwe
+ Kleine-König <Uwe.Kleine-Koenig@digi.com> (Closes: #454470)
+ * git-import-dsc: return non null on failure
+
+ -- Guido Guenther <agx@sigxcpu.org> Fri, 07 Dec 2007 23:19:39 +0100
+
git-buildpackage (0.4.9~bpo.1) etch-backports; urgency=low
* Rebuild for Etch backports.
diff --git a/debian/control b/debian/control
index 26c45356..e8682afe 100644
--- a/debian/control
+++ b/debian/control
@@ -4,8 +4,9 @@ Priority: optional
Maintainer: Guido Guenther <agx@sigxcpu.org>
Build-Depends: cdbs, debhelper (>= 5), python-dev, python-support (>= 0.3),
pychecker, gtk-doc-tools, sgml2x, docbook-utils, jade
-Standards-Version: 3.7.2
+Standards-Version: 3.7.3
Vcs-Git: http://honk.sigxcpu.org/git/git-buildpackage.git/
+Homepage: http://sigxcpu.org/projects.html
Package: git-buildpackage
Architecture: all
diff --git a/debian/dirs b/debian/dirs
deleted file mode 100644
index ca882bbb..00000000
--- a/debian/dirs
+++ /dev/null
@@ -1,2 +0,0 @@
-usr/bin
-usr/sbin
diff --git a/debian/doc-base b/debian/doc-base
new file mode 100644
index 00000000..51ba88fd
--- /dev/null
+++ b/debian/doc-base
@@ -0,0 +1,11 @@
+Document: git-buildpackage
+Title: Git-Buildpackage Manual
+Author: Guido Guenther
+Abstract: git-buildpackage is a suite to help with Debian packages in Git
+ repositories. This manual describes the utilities in this package, their
+ configuration and possible workflows.
+Section: Apps/Programming
+
+Format: HTML
+Index: /usr/share/doc/git-buildpackage/manual-html/index.html
+Files: /usr/share/doc/git-buildpackage/manual-html/*.html
diff --git a/docs/chapters/building.sgml b/docs/chapters/building.sgml
index 4fb85fb6..0bbc836d 100644
--- a/docs/chapters/building.sgml
+++ b/docs/chapters/building.sgml
@@ -28,20 +28,20 @@
<sect1 id="gbp.building.export">
<title>Using a separate build dir</title>
<para>Tools like &svn-buildpackage; use a separate build-area. To achieve a similar behaviour
- with &git-buildpackage; use the <option>--export-dir</option> option:</para>
+ with &git-buildpackage; use the <option>--git-export-dir</option> option:</para>
<screen>
-&git-buildpackage; <option>--export-dir</option>=<replaceable>../build-area/</replaceable>
+&git-buildpackage; <option>--git-export-dir</option>=<replaceable>../build-area/</replaceable>
</screen>
<para>This will export the current branch head to
<replaceable>../build-area/package-version</replaceable>, check out the corresponding
upstream tree to build the .orig.tar.gz if necessary and build the
package. If you don't want to export the current branch head you can use
- <option>--export</option> to export any treeish object, here are some
+ <option>--git-export</option> to export any treeish object, here are some
examples:</para>
<screen>
-&git-buildpackage; <option>--export-dir</option>=<replaceable>../build-area</replaceable> <option>--export</option>=<replaceable>debian/0.4.3</replaceable>
-&git-buildpackage; <option>--export-dir</option>=<replaceable>../build-area</replaceable> <option>--export</option>=<replaceable>etch</replaceable>
-&git-buildpackage; <option>--export-dir</option>=<replaceable>../build-area</replaceable> <option>--export</option>=<replaceable>8caed309653d69b7ab440e3d35abc090eb4c6697</replaceable>
+&git-buildpackage; <option>--git-export-dir</option>=<replaceable>../build-area</replaceable> <option>--git-export</option>=<replaceable>debian/0.4.3</replaceable>
+&git-buildpackage; <option>--git-export-dir</option>=<replaceable>../build-area</replaceable> <option>--git-export</option>=<replaceable>etch</replaceable>
+&git-buildpackage; <option>--git-export-dir</option>=<replaceable>../build-area</replaceable> <option>--git-export</option>=<replaceable>8caed309653d69b7ab440e3d35abc090eb4c6697</replaceable>
</screen>
<para>If you want to default to build in a separate build area you can
specify the directory to use in the gbp.conf.
@@ -49,9 +49,9 @@
<programlisting>
[git-buildpackage]
# use a build area relative to the git repository
-build-area=../build-area
+export-dir=../build-area
# to use the same build area for all packages use an absolute path:
-#build-area=/home/debian-packages/build-area
+#export-dir=/home/debian-packages/build-area
</programlisting>
</sect1>
</chapter>
diff --git a/gbp/git_utils.py b/gbp/git_utils.py
index 2ad4235c..fffa3f64 100644
--- a/gbp/git_utils.py
+++ b/gbp/git_utils.py
@@ -78,11 +78,13 @@ class GitRepository(object):
def index_files(self):
"""List files in the index"""
- out, ret = self.__git_getoutput('ls-files')
+ out, ret = self.__git_getoutput('ls-files', ['-z'])
if ret:
raise GitRepositoryError, "Error listing files %d" % ret
- files = [ line.strip() for line in out ]
- return files
+ if out:
+ return [ file for file in out[0].split('\0') if file ]
+ else:
+ return []
def build_tag(format, version):
diff --git a/git-dch b/git-dch
index b98ce378..cb0e015b 100755
--- a/git-dch
+++ b/git-dch
@@ -187,6 +187,7 @@ def main(argv):
ret = 0
changelog = 'debian/changelog'
until = 'HEAD'
+ found_snapshot_header = False
parser = GbpOptionParser(command=os.path.basename(argv[0]), prefix='',
usage='%prog [options] paths')
@@ -237,6 +238,7 @@ def main(argv):
since = guess_snapshot_commit(cp)
if since:
print "Continuing from commit '%s'" % since
+ found_snapshot_header = True
else:
print "Couldn't get snapshot header, using version info"
if not since:
@@ -246,7 +248,7 @@ def main(argv):
print "Only looking for changes on '%s'" % " ".join(args)
changes = get_log(since, until, options.git_log, " ".join(args))
if changes:
- if cp['Distribution'] != "UNRELEASED":
+ if cp['Distribution'] != "UNRELEASED" and not found_snapshot_header:
add_changelog_section(distribution="UNRELEASED", msg="UNRELEASED")
shortlog_to_dch(changes)
fixup_trailer()
diff --git a/git-import-dsc b/git-import-dsc
index 51ce56a8..37de62d7 100755
--- a/git-import-dsc
+++ b/git-import-dsc
@@ -226,8 +226,9 @@ def main(argv):
ret = 1
os.chdir(dirs['top'])
- if not ret:
- print 'Everything imported under %s' % src.pkg
+ if not ret:
+ print 'Everything imported under %s' % src.pkg
+ return ret
if __name__ == '__main__':
sys.exit(main(sys.argv))
diff --git a/git-import-orig b/git-import-orig
index 284bf0dc..f3344bec 100755
--- a/git-import-orig
+++ b/git-import-orig
@@ -140,8 +140,8 @@ def main(argv):
if not repo.has_branch(options.upstream_branch) and not is_empty:
print >>sys.stderr, """
Repository does not have branch '%s' for upstream sources. If there is none see
-/usr/share/doc/git-buildpackage/manual-html/gbpc.import.convert.html on howto
-create it otherwise use --upstream-branch to specify it.
+file:///usr/share/doc/git-buildpackage/manual-html/gbp.import.html#GBP.IMPORT.CONVERT
+on howto create it otherwise use --upstream-branch to specify it.
""" % options.upstream_branch
raise GbpError