summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2013-03-29 13:15:18 +0100
committerGuido Günther <agx@sigxcpu.org>2013-04-06 18:36:18 +0200
commite5d9816d11418ebf08e961696f8869afe201ce32 (patch)
tree03985a81f58e45573d366377f9fdae5b8c16c8d0
parent920053ee48d61df6166f21aa0f57e40480cc4cdc (diff)
Generate coverage xml
for cobertura style coverage information that can be picked up by e.g. Jenkins
-rw-r--r--.gitignore1
-rw-r--r--debian/control4
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
4 files changed, 6 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 0cc670d7..6467b54b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@
.noseids
.coverage
.ropeproject/
+coverage.xml
gbp/version.py
build/
gbp.egg-info/
diff --git a/debian/control b/debian/control
index 027ceca3..6ec4c388 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,9 @@ Section: vcs
Priority: optional
Maintainer: Guido Günther <agx@sigxcpu.org>
Build-Depends: debhelper (>= 7.0.50~), python (>> 2.6.6-3~),
- pychecker, gtk-doc-tools, sgml2x, docbook-utils, jade, python-dateutil, python-nose,
+ pychecker, gtk-doc-tools, sgml2x, docbook-utils, jade, python-dateutil,
+ python-nose,
+ python-nosexcover,
bash-completion, perl, python-epydoc, python-coverage, python-setuptools,
# For the testsuite
git (>= 1:1.7.9.1-1~), bzip2, unzip, pristine-tar, devscripts
diff --git a/setup.cfg b/setup.cfg
index 4f8d89a0..ba523b92 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[nosetests]
with-doctest=1
-with-coverage=1
+with-xcoverage=1
with-xunit=1
cover-package=gbp
cover-erase=1
diff --git a/setup.py b/setup.py
index d43ca6b0..7fe71b7c 100644
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,6 @@ setup(name = "gbp",
'bin/git-pbuilder'],
packages = find_packages(exclude=['tests', 'tests.*']),
data_files = [("/etc/git-buildpackage/", ["gbp.conf"]),],
- setup_requires=['nose>=0.11.1', 'coverage>=2.85'] if \
+ setup_requires=['nose>=0.11.1', 'coverage>=2.85', 'nosexcover>=1.0.7'] if \
os.getenv('WITHOUT_NOSETESTS') is None else []
)