aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-01-22 21:37:43 +0100
committerGuido Günther <agx@sigxcpu.org>2015-01-22 22:40:09 +0100
commit644c97f37ce91d464988eddc5f60624a06ff8e73 (patch)
treed30dce7b94057fdb1fd9c1f366d27d9595622c31
parent428e8957efc79f4db8dd62b131242dde89d5a72a (diff)
dch: Support Gbp-Dch: besides Git-Dch:
-rw-r--r--docs/chapters/releases.sgml8
-rw-r--r--docs/manpages/gbp-dch.sgml36
-rw-r--r--gbp/dch.py2
3 files changed, 26 insertions, 20 deletions
diff --git a/docs/chapters/releases.sgml b/docs/chapters/releases.sgml
index abc08fd9..64ad2061 100644
--- a/docs/chapters/releases.sgml
+++ b/docs/chapters/releases.sgml
@@ -106,7 +106,7 @@ included into the changelog:
To exclude a commit from the generated changelog use:
</para><para>
<screen>
-Git-Dch: Ignore
+Gbp-Dch: Ignore
</screen>
This is e.g. useful if you're just fixing up a previous commit and couldn't
ammend it or for other janitorial commits that really don't need to end up in
@@ -114,20 +114,20 @@ the changelog. For example, the following git commit message
<screen>
Set correct branchnames in debian/gbp.conf
-Git-Dch: Ignore
+Gbp-Dch: Ignore
</screen>
will not show up in the generated changelog in any way.
</para>
<para>
To include the full commit message in the changelog use:
<screen>
-Git-Dch: Full
+Gbp-Dch: Full
</screen>
</para>
<para>
To only include the short description in the changelog and skip the body use:
<screen>
-Git-Dch: Short
+Gbp-Dch: Short
</screen>
The latter only takes effect when running &gbp-dch; with the
<option>--full</option> option, since including only the short
diff --git a/docs/manpages/gbp-dch.sgml b/docs/manpages/gbp-dch.sgml
index 22ab5688..5303c628 100644
--- a/docs/manpages/gbp-dch.sgml
+++ b/docs/manpages/gbp-dch.sgml
@@ -13,8 +13,8 @@
&dhsection;
</refmeta>
<refnamediv>
- <refname>git-dch;</refname>
- <refname>gbp-dch;</refname>
+ <refname>git-dch</refname>
+ <refname>gbp-dch</refname>
<refpurpose>Generate the &debian; changelog from git commit messages</refpurpose>
</refnamediv>
<refsynopsisdiv>
@@ -147,7 +147,7 @@
<listitem>
<para>
Parse meta tags like <option>Closes:</option>,
- <option>Thanks:</option> and <option>Git-Dch:</option>. See META TAGS
+ <option>Thanks:</option> and <option>Gbp-Dch:</option>. See META TAGS
below.
</para>
</listitem>
@@ -408,19 +408,25 @@
</para>
<variablelist>
<varlistentry>
- <term><option>Git-Dch</option>: <replaceable>action</replaceable>
- </term>
+ <term>
+ <option>Gbp-Dch</option>: <replaceable>action</replaceable>
+ </term>
<listitem>
<para>
- Supported actions are: <replaceable>Ignore</replaceable> which will
- ignore this commit when generating
- <filename>debian/changelog</filename>,
- <replaceable>Short</replaceable> which will only use the description
- (the first line) of the commit message when generating the changelog
- entry (useful when <option>--full</option> is given) and
- <replaceable>Full</replaceable> which will use the full commit
- message when generating the changelog entry (useful when
- <option>--full</option> is not given).
+ Supported actions are: <replaceable>Ignore</replaceable>
+ which will ignore this commit when
+ generating <filename>debian/changelog</filename>,
+ <replaceable>Short</replaceable> which will only use the
+ description (the first line) of the commit message when
+ generating the changelog entry (useful
+ when <option>--full</option> is given) and
+ <replaceable>Full</replaceable> which will use the full
+ commit message when generating the changelog entry (useful
+ when <option>--full</option> is not given).
+ </para>
+ <para>
+ Insteaad of <option>Gbp-Dch</option> the
+ deprecated <option>Git-Dch</option> is still supported.
</para>
</listitem>
</varlistentry>
@@ -453,7 +459,7 @@
so one doesn't have to consult the manual
- Git-Dch: Short
+ Gbp-Dch: Short
Closes: #636088
Thanks: Raphaël Hertzog for the suggestion
</screen>
diff --git a/gbp/dch.py b/gbp/dch.py
index f983234f..d6385ef3 100644
--- a/gbp/dch.py
+++ b/gbp/dch.py
@@ -28,7 +28,7 @@ def extract_git_dch_cmds(lines, options):
commands = {}
other_lines = []
for line in lines:
- if line.startswith('Git-Dch: '):
+ if line.startswith('Git-Dch: ') or line.startswith('Gbp-Dch: '):
cmd = line.split(' ', 1)[1].strip().lower()
commands[cmd] = True
else: