aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-11-15 11:40:57 +0100
committerGuido Günther <agx@sigxcpu.org>2016-11-15 12:35:10 +0100
commit039a2860defb82b29ae50229ba35a8713a96d461 (patch)
tree60ff558d14f7035cd9ccdd1a2811aadeda6f9c3f
parent4cacaeb06e54d860f0848be291776491c4ed053f (diff)
Avoid deprecation outside of Debian package repositories
E.g. ~ might have a .gbp.conf for the user and might be git managed.
-rw-r--r--gbp/config.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/gbp/config.py b/gbp/config.py
index 8f077ba8..8518e0ce 100644
--- a/gbp/config.py
+++ b/gbp/config.py
@@ -729,6 +729,10 @@ class GbpOptionParserDebian(GbpOptionParser):
'builder': 'debuild -i -I',
})
+ def _warn_old_gbp_conf(self, gbp_conf):
+ if os.path.exists("debian/control"):
+ GbpOptionParser._warn_old_gbp_conf(self, gbp_conf)
+
class GbpOptionParserRpm(GbpOptionParser):
"""