aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-09-12 18:44:48 +0200
committerGuido Günther <agx@sigxcpu.org>2016-09-12 18:51:44 +0200
commit264090ee71148b8f88046d68da18fe0f4652e149 (patch)
tree17d1097f5b92ab4fa5750ad1f0afa0a9d1c1ef09
parent28453597a128c355575e0578cbd22e2c49853db5 (diff)
Rename README to README.md
to get Markdown formatting
-rw-r--r--README.md (renamed from README)0
-rw-r--r--debian/docs2
-rwxr-xr-xsetup.py2
-rw-r--r--tests/02_test_upstream_source_tar_unpack.py4
4 files changed, 4 insertions, 4 deletions
diff --git a/README b/README.md
index 9242c07e..9242c07e 100644
--- a/README
+++ b/README.md
diff --git a/debian/docs b/debian/docs
index ce06068d..00356a6c 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1,3 +1,3 @@
-README
+README.md
docs/manual-html/
build/apidocs/
diff --git a/setup.py b/setup.py
index a5597340..a8f2a332 100755
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ def fetch_version():
def readme():
- with open('README') as file:
+ with open('README.md') as file:
return file.read()
diff --git a/tests/02_test_upstream_source_tar_unpack.py b/tests/02_test_upstream_source_tar_unpack.py
index e6440903..ec4983d7 100644
--- a/tests/02_test_upstream_source_tar_unpack.py
+++ b/tests/02_test_upstream_source_tar_unpack.py
@@ -27,7 +27,7 @@ class TestUnpack(unittest.TestCase):
assert os.path.exists(target), "%s does not exist" % target
def _create_archive(self, comp):
- filelist = ['README', 'setup.py']
+ filelist = ['README.md', 'setup.py']
name = "%s_0.1.tar.%s" % (self.archive_prefix, comp)
t = tarfile.open(name=name, mode='w:%s' % comp)
@@ -72,7 +72,7 @@ class TestUnpack(unittest.TestCase):
self._check_files(archive[1], comp)
def test_upstream_source_unpack_filtered(self):
- exclude = "README"
+ exclude = "README.md"
for (comp, archive) in six.iteritems(self.archives):
source = gbp.pkg.UpstreamSource(archive[0])