aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-09-28 08:36:56 +0200
committerGuido Günther <agx@sigxcpu.org>2016-09-28 08:36:56 +0200
commitc1ab85ad188f073b99b407a87cb784408d806cf9 (patch)
treef7cdf31270d08f2651d1cb7e82f72e67d3b7a564
parentf31bcd2d15df5b87bcb03d7da8ee87cea1aab500 (diff)
test_pq_rpm: flake8 clean
-rw-r--r--tests/component/rpm/test_pq_rpm.py16
1 files changed, 8 insertions, 8 deletions
diff --git a/tests/component/rpm/test_pq_rpm.py b/tests/component/rpm/test_pq_rpm.py
index c329f7a5..1861fcc2 100644
--- a/tests/component/rpm/test_pq_rpm.py
+++ b/tests/component/rpm/test_pq_rpm.py
@@ -18,7 +18,7 @@
import os
import tempfile
-from nose.tools import assert_raises, eq_, ok_ # pylint: disable=E0611
+from nose.tools import assert_raises, eq_, ok_ # pylint: disable=E0611
from gbp.scripts.pq_rpm import main as pq
from gbp.git import GitRepository
@@ -35,6 +35,7 @@ def mock_pq(args):
# Call pq-rpm with added arg0
return pq(['arg0'] + args)
+
class TestPqRpm(RpmRepoTestBase):
"""Basic tests for gbp-pq-rpm"""
@@ -59,7 +60,7 @@ class TestPqRpm(RpmRepoTestBase):
"""Run pq-rpm when not in a git repository"""
eq_(mock_pq(['export']), 1)
self._check_log(0, 'gbp:error: %s is not a git repository' %
- os.path.abspath(os.getcwd()))
+ os.path.abspath(os.getcwd()))
def test_import_export(self):
"""Basic test for patch import and export"""
@@ -317,7 +318,7 @@ class TestPqRpm(RpmRepoTestBase):
eq_(mock_pq(['export']), 0)
files = ['.gbp.conf', '.gitignore', 'bar.tar.gz', 'foo.txt',
'gbp-test.spec', 'my.patch',
- '%s-to-%s.diff' % (upstr_rev, merge_rev), '0002-my2.patch']
+ '%s-to-%s.diff' % (upstr_rev, merge_rev), '0002-my2.patch']
self._check_repo_state(repo, 'master', branches, files)
def test_import_unapplicable_patch(self):
@@ -329,10 +330,10 @@ class TestPqRpm(RpmRepoTestBase):
patch_file.write('-this-does\n+not-apply\n')
eq_(mock_pq(['import']), 1)
self._check_log(-2, "("
- "Aborting|"
- "Please, commit your changes or stash them|"
- "gbp:error: Import failed.* You have local changes"
- ")")
+ "Aborting|"
+ "Please, commit your changes or stash them|"
+ "gbp:error: Import failed.* You have local changes"
+ ")")
self._check_repo_state(repo, 'master', branches)
# Now commit the changes to the patch and try again
@@ -341,4 +342,3 @@ class TestPqRpm(RpmRepoTestBase):
eq_(mock_pq(['import']), 1)
self._check_log(-2, "gbp:error: Import failed: Error running git apply")
self._check_repo_state(repo, 'master', branches)
-