aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2017-01-17 20:10:00 +0100
committerGuido Günther <agx@sigxcpu.org>2017-01-17 20:11:07 +0100
commit3f4b9f89e1baa2f23140fcb87519da3afc3f12ae (patch)
treef0f81bacb6137cc8aacebed7073f9b0ef1f15e0f
parent0fdff8e5277f3388f3879039918b126b8cf9eae0 (diff)
make: Check if we can use parallel flake
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e512cfe8..ad61026f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,5 @@
PY_EXAMPLES=$(shell grep -l /usr/bin/python examples/*)
+FLAKE_OPTS=$(shell test -w /dev/shm || echo '-j1')
all: syntax-check test
@@ -14,8 +15,8 @@ test:
python setup.py nosetests --with-xcoverage
syntax-check:
- flake8 -j1
- flake8 -j1 $(PY_EXAMPLES)
+ flake8 $(FLAKE_OPTS)
+ flake8 $(FLAKE_OPTS) $(PY_EXAMPLES)
docs:
make -C docs