aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2017-01-18 08:23:21 +0100
committerGuido Günther <agx@sigxcpu.org>2017-01-18 08:23:21 +0100
commit5211ab98f09f77082841538a1b3db935b2f21a2f (patch)
tree4f172ba8fae13100f1a8806c1b567128b3ee5003
parent534c055c6e6dd599a022cd16107083155c7560a2 (diff)
git-pbuilder: Pass --debbuildopts to pbuilder instead of pdebuild
This requires at least pbuilder 0.228 Closes: #851657
-rw-r--r--bin/git-pbuilder10
-rw-r--r--debian/control1
2 files changed, 7 insertions, 4 deletions
diff --git a/bin/git-pbuilder b/bin/git-pbuilder
index e67698de..caa28d7c 100644
--- a/bin/git-pbuilder
+++ b/bin/git-pbuilder
@@ -327,11 +327,13 @@ done
# Now we can finally run pdebuild. The quoting here is tricky, but this
# seems to pass everything through properly.
if [ no = "$GIT_PBUILDER_AUTOCONF" ] ; then
- pdebuild --pbuilder "$BUILDER" --debbuildopts "$DEBBUILDOPTS" \
- "${PDEBUILDOPTS[@]}" -- "${OPTIONS[@]}"
+ pdebuild \
+ --pbuilder "$BUILDER" "${PDEBUILDOPTS[@]}" -- \
+ --debbuildopts "$DEBBUILDOPTS" "${OPTIONS[@]}"
else
- pdebuild --buildresult "$OUTPUT_DIR" --pbuilder "$BUILDER" \
- --debbuildopts "$DEBBUILDOPTS" "${PDEBUILDOPTS[@]}" -- "${OPTIONS[@]}"
+ pdebuild --buildresult "$OUTPUT_DIR" \
+ --pbuilder "$BUILDER" "${PDEBUILDOPTS[@]}" -- \
+ --debbuildopts "$DEBBUILDOPTS" "${OPTIONS[@]}"
fi
exit "$?"
diff --git a/debian/control b/debian/control
index fd7d621c..56bd60bd 100644
--- a/debian/control
+++ b/debian/control
@@ -56,6 +56,7 @@ Recommends: pristine-tar (>= 0.5),
cowbuilder | pbuilder | sbuild,
python-requests
Suggests: python-notify, unzip, sudo
+Breaks: pbuilder (<< 0.228~)
Description: Suite to help with Debian packages in Git repositories
This package contains the following tools:
* gbp import-{dsc,dscs}: import existing Debian source packages into a git