aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2017-01-21 09:32:38 +0100
committerGuido Günther <agx@sigxcpu.org>2017-01-21 09:34:54 +0100
commit8bf30ffeb8431583dbd447153527a9ae53cdc55a (patch)
tree849f7bb26a047bf89d145047179191ab4213025a
parentf30bb9896f83f2c3d3c74de78e22f53d5849de9e (diff)
Make is simple to override nose flags on the command line
e.g. for passing in -x
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ad61026f..cfd997b1 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,6 @@
PY_EXAMPLES=$(shell grep -l /usr/bin/python examples/*)
FLAKE_OPTS=$(shell test -w /dev/shm || echo '-j1')
+NOSE_FLAGS=--with-xcoverage
all: syntax-check test
@@ -12,7 +13,7 @@ test:
export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
PYTHONPATH=. \
- python setup.py nosetests --with-xcoverage
+ python setup.py nosetests $(NOSE_FLAGS)
syntax-check:
flake8 $(FLAKE_OPTS)