aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2012-04-18 08:14:40 +0200
committerGuido Günther <agx@sigxcpu.org>2012-04-18 08:14:40 +0200
commit3b34b2626fa5e87fafb7cf326744927035794932 (patch)
tree8b31caa08ecf83510eb7c83381cfda1b1108bc0b
parent3ff30ff2b049ace59fd4736059881a5559517f08 (diff)
Make building with DEB_BUILD_OPTIONS=nocheck skip all tests
heavily based on a patch by Matthijs Kooijman
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 6360dffd..2c40befc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,7 @@ PYCHECKER_ARGS=-boptparse --no-override --no-shadowbuiltin
dh $@ --with python2
override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
dh_auto_test
export GIT_AUTHOR_NAME="Gbp Tests"; \
export GIT_AUTHOR_EMAIL=tests@example.com; \
@@ -25,6 +26,9 @@ override_dh_auto_test:
PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q \
gbp gbp.scripts gbp.git gbp.deb
+else
+ @echo "Checks disabled via DEB_BUILD_OPTIONS"
+endif
override_dh_auto_build:
dh_auto_build