aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2012-02-18 16:26:19 +0100
committerGuido Günther <agx@sigxcpu.org>2012-02-18 16:26:19 +0100
commit8acec833e27892f74d10811cf95516b4380234ba (patch)
treea4e4cf6708407dcb01f039c6a585408f89c592fc
parent38afb27a1e3c792e1989f338428f31f46271abab (diff)
parent1e1ae2ecae0660ce1e5cc1e97a77b2999b46cb3c (diff)
Merge tag 'debian/0.6.0_git20120218' into experimental
Debian release 0.6.0~git20120218
-rw-r--r--debian/changelog16
-rw-r--r--debian/control4
-rwxr-xr-xgbp/scripts/pq.py2
-rw-r--r--setup.py2
4 files changed, 20 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 9407334a..7f996ab0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+git-buildpackage (0.6.0~git20120218) unstable; urgency=low
+
+ [ Markus Lehtonen ]
+ * [24e7725] Make pristine_tar testcases pass with older git versions that
+ don't support user-defined output formats (tar filters) in git-archive.
+
+ [ Guido Günther ]
+ * [14d36c0] Depend on git instead of git-core (Closes: #659661)
+ * [f25fa9b] Lower dependencies on python-nose and python-coverage the
+ versions in Squeeze are recent enough.
+ * [7e41626] Require git 1.7 which is already in Squeeze and Lenny Backports
+ * [63411b7] gbp-pq: Properly print patch name when guessing authorship
+ information
+
+ -- Guido Günther <agx@sigxcpu.org> Sat, 18 Feb 2012 16:16:48 +0100
+
git-buildpackage (0.6.0~git20120210) unstable; urgency=low
* [d279757] PristineTar: fix links in testcases
diff --git a/debian/control b/debian/control
index ee40381f..f9011ab3 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Build-Depends: debhelper (>= 7.0.50~), python (>> 2.6.6-3~),
pychecker, gtk-doc-tools, sgml2x, docbook-utils, jade, python-dateutil, python-nose,
bash-completion, perl, python-epydoc, python-coverage, python-setuptools,
# For the testsuite
- git-core, bzip2, unzip, pristine-tar
+ git, bzip2, unzip, pristine-tar
Standards-Version: 3.9.2
Vcs-Git: git://honk.sigxcpu.org/git/git-buildpackage.git
Vcs-Browser: http://git.debian.org/?p=users/agx/git-buildpackage.git
@@ -16,7 +16,7 @@ X-Python-Version: >= 2.6
Package: git-buildpackage
Architecture: all
Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, devscripts (>= 2.10.66~),
- git (>= 1:1.7.0.4-2) | git-core (>= 1:1.5.0.1-1), python-dateutil
+ git (>= 1:1.7.0.4-2), python-dateutil
Recommends: pristine-tar (>= 0.5), cowbuilder
Suggests: python-notify, unzip
Description: Suite to help with Debian packages in Git repositories
diff --git a/gbp/scripts/pq.py b/gbp/scripts/pq.py
index dbb4618c..ec9ae6d2 100755
--- a/gbp/scripts/pq.py
+++ b/gbp/scripts/pq.py
@@ -286,7 +286,7 @@ def apply_and_commit_patch(repo, patch, topic=None):
name, email = get_maintainer_from_control()
if name:
gbp.log.warn("Patch '%s' has no authorship information, "
- "using '%s <%s>'" % (patch, name, email))
+ "using '%s <%s>'" % (patch.path, name, email))
author['name'] = name
author['email'] = email
else:
diff --git a/setup.py b/setup.py
index 9a0cb590..b9342c2a 100644
--- a/setup.py
+++ b/setup.py
@@ -57,5 +57,5 @@ setup(name = "gbp",
'bin/git-pbuilder'],
packages = find_packages(),
data_files = [("/etc/git-buildpackage/", ["gbp.conf"]),],
- setup_requires=['nose>=1.0', 'coverage>=3.4'],
+ setup_requires=['nose>=0.11.1', 'coverage>=2.85'],
)