aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorMatthijs Kooijman <matthijs@stdin.nl>2012-04-17 22:41:48 +0200
committerGuido Günther <agx@sigxcpu.org>2012-04-18 09:38:04 +0200
commita43e9b9b2c95fe7f3252fb9c6c3de861c7f8d4a6 (patch)
tree38a6629da44aa3480ef52382dbc4ff5e6e95e0d5
parent3b34b2626fa5e87fafb7cf326744927035794932 (diff)
Git-Dch: Full in commit messages
This new tag makes git-dch use the full commit message when generating the Debian changelog file, even when --full is not given. Closes: #669159 Signed-off-by: Guido Günther <agx@sigxcpu.org>
-rw-r--r--docs/chapters/releases.sgml12
-rw-r--r--docs/manpages/git-dch.sgml11
-rw-r--r--gbp/dch.py2
3 files changed, 19 insertions, 6 deletions
diff --git a/docs/chapters/releases.sgml b/docs/chapters/releases.sgml
index 9d3bf747..d5cf0871 100644
--- a/docs/chapters/releases.sgml
+++ b/docs/chapters/releases.sgml
@@ -119,11 +119,19 @@ Git-Dch: Ignore
will not show up in the generated changelog in any way.
</para>
<para>
-To only include the short description in the commit and skip the body use:
+To include the full commit message in the changelog use:
+<screen>
+Git-Dch: Full
+</screen>
+</para>
+<para>
+To only include the short description in the changelog and skip the body use:
<screen>
Git-Dch: Short
</screen>
-This only takes effect when running &git-dch; with the <option>--full</option> option.
+The latter only takes effect when running &git-dch; with the
+<option>--full</option> option, since including only the short
+description is the default.
</para>
<para>
Usually changelog entries should correspond to a single &git; commit. In this case it's
diff --git a/docs/manpages/git-dch.sgml b/docs/manpages/git-dch.sgml
index 3059f8d2..6dfe7bb9 100644
--- a/docs/manpages/git-dch.sgml
+++ b/docs/manpages/git-dch.sgml
@@ -259,9 +259,14 @@
</term>
<listitem><para>
Supported actions are: <replaceable>Ignore</replaceable> which will ignore
- this commit when generating <filename>debian/changelog</filename> and
- <replaceable>Short</replaceable> which will only use the description
- (the first line) of the commit message when generating the changelog entry.
+ this commit when generating <filename>debian/changelog</filename>,
+ <replaceable>Short</replaceable> which will only use the
+ description (the first line) of the commit message when
+ generating the changelog entry (useful when
+ <option>--full</option> is given) and
+ <replaceable>Full</replaceable> which will use the full commit
+ message when generating the changelog entry (useful when
+ <option>--full</option> is not given).
</para></listitem>
</varlistentry>
<varlistentry>
diff --git a/gbp/dch.py b/gbp/dch.py
index c481c16f..ddd5e8e9 100644
--- a/gbp/dch.py
+++ b/gbp/dch.py
@@ -119,7 +119,7 @@ def format_changelog_entry(commit_info, options, last_commit=False):
(thanks, body) = extract_thanks_info(body, options)
body = filter_ignore_rx_matches(body, options)
- if options.full and not 'short' in git_dch_cmds:
+ if 'full' in git_dch_cmds or (options.full and not 'short' in git_dch_cmds):
# Add all non-blank body lines.
entry.extend([line for line in body if line.strip()])
if thanks: