summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2017-11-06 19:22:03 +0100
committerGuido Günther <agx@sigxcpu.org>2017-11-06 19:24:08 +0100
commit2343b5cb84dffb596955ea5d113d59be6054f508 (patch)
treef2a45b63106fc261099f62fd3c22391a6ee5df94 /Makefile
parente972bc97a47a57359fc6793f61e0022fd123b5d5 (diff)
Make it simple to switch the locale tests are run under
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 80d116ff..56e23f3a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
PY_EXAMPLES=$(shell grep -l /usr/bin/python examples/*)
FLAKE_OPTS=$(shell test -w /dev/shm || echo '-j1')
NOSE_OPTS=--with-xcoverage
+TEST_LOCALE=C.UTF-8
all: syntax-check test
@@ -13,7 +14,7 @@ test:
export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
PYTHONPATH=. \
- LC_ALL=C.UTF-8 python3 setup.py nosetests $(NOSE_OPTS)
+ LC_ALL=$(TEST_LOCALE) python3 setup.py nosetests $(NOSE_OPTS)
syntax-check:
flake8 $(FLAKE_OPTS)