summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-12-22 15:11:58 +0100
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-12-22 15:11:58 +0100
commit2f3c8a58d8b7d75045244413b3a3db507c8d5b82 (patch)
tree2c1db18fecead41bc1ca5b29d2c6577bc18bfff9 /debian
parent69e776a291872d0b20f5a55527b68ea09996b920 (diff)
add some more documentation
some of the layout is based on what darcs-buildpackage does
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/docs1
-rw-r--r--debian/links1
-rwxr-xr-xdebian/rules10
4 files changed, 16 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 280f333f..19e961ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+git-buildpackage (0.2.20) unstable; urgency=low
+
+ * add some more documentation
+
+ -- Guido Guenther <agx@sigxcpu.org> Fri, 22 Dec 2006 15:05:09 +0100
+
git-buildpackage (0.2.19) unstable; urgency=low
* git-buildpackage: add an option (--git-cleaner) that allows to specify
diff --git a/debian/docs b/debian/docs
index e845566c..7fdec518 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1 +1,2 @@
README
+docs/manual-html/
diff --git a/debian/links b/debian/links
new file mode 100644
index 00000000..803c8fee
--- /dev/null
+++ b/debian/links
@@ -0,0 +1 @@
+/usr/share/doc/git-buildpackage/manual-html/gbp.html /usr/share/doc/git-buildpackage/manual-html/index.html
diff --git a/debian/rules b/debian/rules
index 6ea935f3..4cea6597 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,17 +9,23 @@ include /usr/share/cdbs/1/class/python-distutils.mk
COMMANDS=git-buildpackage git-import-dsc git-import-orig
MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS))
+MANUAL=docs/manual-html
PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
PYCHECK_LEVEL=Error
docs/%.1: docs/man.%.sgml
docbook-to-man $< > $@
+$(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
+ docbook-2-html -s gtk $<
+
%.py: %
ln -s $< $@
PYTHONPATH=. pychecker -e $(PYCHECK_LEVEL) -q $<
-build/git-buildpackage:: $(MANPAGES) $(PYCHECKS)
+build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(PYCHECKS)
clean::
- -rm docs/*.1 git-*.py
+ -rm docs/*.1 git-*.py
+ -rm -rf docs/manual-html/
+