aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-11-16 08:57:27 +0100
committerGuido Günther <agx@sigxcpu.org>2015-11-16 08:57:27 +0100
commitbfe32f19e7a2a24b93b36467772254583c34b6ff (patch)
tree73691e068c34f3348a1dcf0274c45313627b9929 /debian
parent82a847df8a04f598dafa31af46b9493255a6f033 (diff)
buildpackage-rpm: add support for mock chroot builder
Try: gbp buildpackage-rpm --git-mock --git-dist=epel-6 Results will be under ../rpmbuild/results/ This is very heavily based on a patch from Tzafrir Cohen.
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/git-buildpackage-rpm.install1
-rw-r--r--debian/git-buildpackage.install3
3 files changed, 4 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 8504b104..ca333543 100644
--- a/debian/control
+++ b/debian/control
@@ -73,7 +73,7 @@ Depends: ${python:Depends},
python-rpm,
rpm,
Recommends: pristine-tar (>= 0.5)
-Suggests: python-notify, unzip
+Suggests: python-notify, unzip, mock
Description: Suite to help with RPM packages in Git repositories
This package contains the following tools:
* gbp buildpackage-rpm: build a package out of a git repository, check for
diff --git a/debian/git-buildpackage-rpm.install b/debian/git-buildpackage-rpm.install
index 5178cb37..54d7f958 100644
--- a/debian/git-buildpackage-rpm.install
+++ b/debian/git-buildpackage-rpm.install
@@ -1,3 +1,4 @@
+usr/bin/gbp-builder-mock /usr/share/git-buildpackage/
usr/lib/python2.?/dist-packages/gbp/rpm/
usr/lib/python2.7/dist-packages/gbp/scripts/import_srpm.py
usr/lib/python2.7/dist-packages/gbp/scripts/pq_rpm.py
diff --git a/debian/git-buildpackage.install b/debian/git-buildpackage.install
index 1a25e1dc..1cf7c4ca 100644
--- a/debian/git-buildpackage.install
+++ b/debian/git-buildpackage.install
@@ -1,4 +1,5 @@
-usr/bin/
+usr/bin/gbp
+usr/bin/git-pbuilder
usr/lib/python2.?/dist-packages/gbp-*
usr/lib/python2.?/dist-packages/gbp/command_wrappers.py
usr/lib/python2.?/dist-packages/gbp/config.py