summaryrefslogtreecommitdiffhomepage
path: root/docs
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-07-02 21:04:11 +0200
committerGuido Günther <agx@sigxcpu.org>2016-07-03 13:21:36 +0200
commitd9773773945275d7e3230dd4cc50f86a23018f9b (patch)
treeef14c4bbca59c31c9b335149e97866ed81e6ef47 /docs
parentd92b656799ca50abec3883cea773cc0e5529a434 (diff)
Set date in manpages based on last changelog entry
for reproducibility. This can be reverted once ocbook2man is fixed (#800797). Thanks: Sascha Steinbiss for the patch
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 71f99837..1f9dcfed 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -28,6 +28,7 @@ VERSION_ENT=version.ent
GBP_VERSION=../gbp/version.py
DEB_VERSION=$(shell sed -ne 's/^gbp_version="\([.a-z0-9~-]\+\)"/\1/p' $(GBP_VERSION))
CHANGELOG=../debian/changelog
+MAN_DATE=$(shell dpkg-parsechangelog -l ../debian/changelog -SDate | TZ=UTC LC_ALL=C date -f- +'%d %B %Y')
# Stuff to build docs outside Debian
HAVE_SGML2X ?= 1
@@ -50,12 +51,14 @@ BUILD_MAN_XREF_PAGES=$(patsubst %,buildxref/%,$(SGML_MANPAGES))
buildxref/%.1 buildxref/%.5: man.%.sgml manpages/%.sgml
docbook2man -o buildxref $<
+ sed -i -r "s/\"[^\"]+\"/\"$(MAN_DATE)\"/3" $@
manpage.refs: $(BUILD_MAN_XREF_PAGES)
cp buildxref/$@ $@
%.1 %.5: manpage.refs
docbook2man -o . man.$*.sgml
+ sed -i -r "s/\"[^\"]+\"/\"$(MAN_DATE)\"/3" $@
git-pbuilder.1: ../bin/git-pbuilder
pod2man $< $@