summaryrefslogtreecommitdiffhomepage
path: root/docs
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-01-22 14:21:33 +0100
committerGuido Günther <agx@sigxcpu.org>2015-01-22 22:40:09 +0100
commit428e8957efc79f4db8dd62b131242dde89d5a72a (patch)
treef713b00117892a3f75884d5c92f8ce1db6516c0f /docs
parent0ab70aa48d16b58ecbd4d41ac006dea14631b4e5 (diff)
Make Debian and Git spelling consistent
Diffstat (limited to 'docs')
-rw-r--r--docs/chapters/building.sgml8
-rw-r--r--docs/chapters/import.sgml32
-rw-r--r--docs/chapters/intro.sgml10
-rw-r--r--docs/chapters/releases.sgml4
-rw-r--r--docs/chapters/special.sgml6
-rw-r--r--docs/manpages/gbp-buildpackage.sgml10
-rw-r--r--docs/manpages/gbp-create-remote-repo.sgml2
-rw-r--r--docs/manpages/gbp-dch.sgml4
-rw-r--r--docs/manpages/gbp-import-dsc.sgml16
-rw-r--r--docs/manpages/gbp-import-orig.sgml8
-rw-r--r--docs/manpages/gbp-pq.sgml6
-rw-r--r--docs/manpages/gbp.sgml8
12 files changed, 57 insertions, 57 deletions
diff --git a/docs/chapters/building.sgml b/docs/chapters/building.sgml
index 495b5850..3b32fbbf 100644
--- a/docs/chapters/building.sgml
+++ b/docs/chapters/building.sgml
@@ -28,7 +28,7 @@
<screen>
&gbp-buildpackage; <option>--git-tag</option>
</screen>
- <para>This will again build the debian package and tag the final result after
+ <para>This will again build the &debian; package and tag the final result after
extracting the current version from the changelog. If you want &gpg; signed
tags you can use the <option>--git-sign</option> and
<option>--git-keyid</option> options. To save typing these option can be
@@ -146,7 +146,7 @@ echo "done."
<option>posttag</option>=<replaceable>"gbp-posttag-push"</replaceable>
</programlisting>
to your <filename>.gbp.conf</filename> and make sure <filename>gbp-push</filename>
- is somewhere in your <envar>$PATH</envar>. On Debian
+ is somewhere in your <envar>$PATH</envar>. On &debian;
systems a more complete example can be found in
<filename>/usr/share/doc/examples/git-buildpackage/examples/gbp-posttag-push</filename>.
</para>
@@ -159,7 +159,7 @@ echo "done."
for the postexport action is to allow further adjustment of
the sources prior to building the package. A typical use case
scenario is to allow creating multiple source and binary
- packages from one Debian branch - e.g. the bootstrap gcc and
+ packages from one &debian; branch - e.g. the bootstrap gcc and
in the next stage the full gcc.
</para>
<para> The postexport action, postpones the creation of the
@@ -179,7 +179,7 @@ echo "done."
export-dir = ../build-area
# disable the since the sources are being exported first
cleaner =
-# post export script that handles expansion of Debian specific files
+# post export script that handles expansion of &debian; specific files
postexport = crosstoolchain-expand.sh
</programlisting>
diff --git a/docs/chapters/import.sgml b/docs/chapters/import.sgml
index 446b1212..4e72975c 100644
--- a/docs/chapters/import.sgml
+++ b/docs/chapters/import.sgml
@@ -3,13 +3,13 @@
<sect1 id="gbp.import.existing">
<title>Importing already existing &debian; packages</title>
- <para>Importing an already exsting debian package into a git repository is as easy as:
+ <para>Importing an already exsting &debian; package into a &git; repository is as easy as:
<screen>
&gbp-import-dsc; package_0.1-1.dsc
</screen>
- This will create a new git repository named after the imported package, put
+ This will create a new &git; repository named after the imported package, put
the upstream sources onto the <option>upstream-branch</option> and the
- debian patch on the <option>debian-branch</option>. In case of a debian
+ &debian; patch on the <option>debian-branch</option>. In case of a debian
native package only the <option>debian-branch</option> is being used.
You can specify alternative branch names via the
<option>--upstream-branch</option> and <option>--debian-branch</option>
@@ -43,7 +43,7 @@ by version number.
<sect1 id="gbp.import.new.upstream">
<title>Importing a new upstream version</title>
- <para>Change into your git repository (which can be empty), make sure it
+ <para>Change into your &git; repository (which can be empty), make sure it
has all local modifications committed and run either of:
<screen>
&gbp-import-orig; <filename>/path/to/package_0.2.orig.tar.gz</filename>
@@ -117,7 +117,7 @@ EOF
<title>Upstream sources not on a branch</title>
<para>
If you don't have an upstream branch but started your repository with only
- the upstream sources (not the debian patch) you can simply branch from that
+ the upstream sources (not the &debian; patch) you can simply branch from that
point. So use &gitkcmd; or &gitcmd;-log to locate the commit-id of that commit
and create the upstream branch from there, e.g.:
<screen>
@@ -126,7 +126,7 @@ EOF
</screen>
The important thing here is that the <envar>COMMIT_ID</envar> specifies a
point on the master branch that carried <emphasis>only</emphasis> the
- upstream sources and not the debian modifications. The above example
+ upstream sources and not the &debian; modifications. The above example
assumes that this was the first commit to that repository.
</para>
<warning><para>There's currently no <emphasis>easy</emphasis> way to create the
@@ -160,7 +160,7 @@ EOF
</sect1>
<sect1 id="gbp.import.fromscratch">
- <title>Starting a Debian package from scratch</title>
+ <title>Starting a &debian; package from scratch</title>
<para>
So far we assumed you already have a &debian; package to start with but
what if you want to start a new package? First create an empty repository:
@@ -171,7 +171,7 @@ EOF
<command>git init</command>
</screen>
<para>Then you import the upstream sources, branch off the
- <option>upstream-branch</option> branch and add the debian files (e.g. via dh_make):
+ <option>upstream-branch</option> branch and add the &debian; files (e.g. via dh_make):
<screen>
&gbp-import-orig; <option>-u</option> <replaceable>0.1</replaceable> <filename>../package-0.1.tar.gz</filename>
<command>dh_make</command>
@@ -181,7 +181,7 @@ EOF
</sect1>
<sect1 id="gbp.import.upstream-git">
- <title>When upstream uses GIT</title>
+ <title>When upstream uses Git</title>
<para>
If upstream already uses git for packaging there are several ways to handle packaging. Two of them will
be described in a bit detail here:
@@ -213,7 +213,7 @@ upstream-tag = v%(version)s
</para>
<para>If you're using &pristine-tar; you can make &gbp-buildpackage commit the generated tarball back to the
pristine-tar branch by using the <option>--git-pristine-tar-commit</option> option. This will make sure
- others building your package can regenerate the tarball you generated for building the Debian pacakge.
+ others building your package can regenerate the tarball you generated for building the &debian; package.
</para>
<sect3>
@@ -223,7 +223,7 @@ upstream-tag = v%(version)s
to &gbp.conf; to save lots of typing.
</para>
- <para>First we clone the upstream repository. To avoid any dis ambiguities between the Debian packaging repository
+ <para>First we clone the upstream repository. To avoid any dis ambiguities between the &debian; packaging repository
and the upstream repository we name the upstream repository <replaceable>ustream</replaceable> instead of the
default <replaceable>origin</replaceable>.
<screen>
@@ -231,9 +231,9 @@ upstream-tag = v%(version)s
cd libgbp
git checkout -b debian/sid v1.0
</screen>
- The above makes sure we have <replaceable>debian/sid</replaceable> for the Debian packaging. We didn't create
+ The above makes sure we have <replaceable>debian/sid</replaceable> for the &debian; packaging. We didn't create
any <replaceable>upstream/*</replaceable> branches, they're not needed for the packaging and only need to be
- kept up to date. After adding the Debian packaging we build the package. This assumes you're using &pristine-tar;
+ kept up to date. After adding the &debian; packaging we build the package. This assumes you're using &pristine-tar;
and upstream uses a version number format as described above:
<screen>
gbp buildpackage --git-pristine-tar --git-pristine-tar-commit --git-upstream-tag='v%(version)s' --git-debian-branch=debian/sid
@@ -262,7 +262,7 @@ upstream-tag = v%(version)s
<sect2 id="gbp.import.upstream.git.tarball">
<title>Upstream tarballs</title>
- <para>If you want to track upstream's git but continue to import the upstream tarballs,
+ <para>If you want to track upstream's &git; but continue to import the upstream tarballs,
e.g. to make sure the tarball uploaded
to &debian; has the same checksum as upstream's you can use the <option>--upstream-vcs-tag</option> option
when importing new tarballs with &gbp-import-orig;. Assuming you have the upstream source in your
@@ -279,7 +279,7 @@ upstream-tag = v%(version)s
<sect1 id="gbp.branch.naming">
<title>Branch layout</title>
<para>
- By default &gbp; uses one branch to keep the Debian packaging called <emphasis>master</emphasis>
+ By default &gbp; uses one branch to keep the &debian; packaging called <emphasis>master</emphasis>
and a branch to keep the upstream packaging called <emphasis>upstream</emphasis>.
</para>
<para>
@@ -294,7 +294,7 @@ upstream-tag = v%(version)s
</term>
<listitem>
<para>
- the Debian packaging for a release <emphasis>jessie</emphasis>,
+ the &debian; packaging for a release <emphasis>jessie</emphasis>,
<emphasis>wheezy</emphasis>, <emphasis>sid</emphasis> or <emphasis>experimental</emphasis>.
</para>
</listitem>
diff --git a/docs/chapters/intro.sgml b/docs/chapters/intro.sgml
index c29d7138..990ca95e 100644
--- a/docs/chapters/intro.sgml
+++ b/docs/chapters/intro.sgml
@@ -28,9 +28,9 @@
<sect1 id="gbp.repository">
<title>Repository Layout and Terminology</title>
- <para>It is recommended to have the Debian packaging on a seprate
+ <para>It is recommended to have the &debian; packaging on a seprate
branch than the upstream source <footnote><para>this, of course, has
- no meaning for Debian native packages</para></footnote>.
+ no meaning for &debian; native packages</para></footnote>.
This is necessary to be able to import
and merge in new upstream versions via &gbp-import-orig;.
To distinguish these two branches the following terminology
@@ -62,7 +62,7 @@
<option>debian-branch</option>. If the <option>debian-branch</option> is called
<emphasis>master</emphasis> the corresponding patch-queue branch is
called <emphasis>patch-queue/master</emphasis>. The patch-queue branch is
- the debian branch plus the contents of
+ the &debian; branch plus the contents of
<emphasis>debian/patches</emphasis> applied. These branches are managed
with &gbp-pq;.
</para></listitem>
@@ -97,14 +97,14 @@
A typical, simple workflow consists of the following steps:
</para>
<orderedlist>
- <listitem><para>Import a new Debian package via &gbp-import-dsc;. This
+ <listitem><para>Import a new &debian; package via &gbp-import-dsc;. This
imports the &debian; Package on the <option>debian-branch</option>
and the upstream sources on the <option>upstream-branch</option>.</para></listitem>
<listitem><para>Develop, test, commit changes. During this time you can
always build the package with &gbp-buildpackage;. In case you have
uncommitted changes in your source tree you can use the
<option>--git-ignore-new</option> option.</para></listitem>
- <listitem><para>Optionally you can create the Debian changelog entries
+ <listitem><para>Optionally you can create the &debian; changelog entries
using &gbp-dch; and create snapshot releases for testing using its
<option>--snapshot</option> option.</para></listitem>
<listitem><para>Once satisfied you can build the final package with
diff --git a/docs/chapters/releases.sgml b/docs/chapters/releases.sgml
index 6f00995a..abc08fd9 100644
--- a/docs/chapters/releases.sgml
+++ b/docs/chapters/releases.sgml
@@ -1,6 +1,6 @@
<chapter id="gbp.releases">
<title>Releases and Snapshots</title>
- <para>When branching and merging frequently, the different Debian changelog
+ <para>When branching and merging frequently, the different &debian; changelog
entries on the different branches tend to get into the way of the automatic
merge and the the merge fails - leaving the (pathological) merge to the
committer. In order to avoid this &gbp-dch; offers a way for creating
@@ -137,7 +137,7 @@ description is the default.
Usually changelog entries should correspond to a single &git; commit. In this case it's
convenient to include the commit id in the changelog entry.
This has the advantage that it's easy for people to identify changes without
-having to write very extensive changelog messages - the link back to Git can be
+having to write very extensive changelog messages - the link back to &git; can be
automated via the <option>Vcs-Browser</option> and <option>Vcs-Git</option>
fields in <filename>debian/control</filename>. See <ulink url="https://honk.sigxcpu.org/cl2vcs">
Cl2vcs</ulink> for how this looks.
diff --git a/docs/chapters/special.sgml b/docs/chapters/special.sgml
index 9c8aa648..7776330f 100644
--- a/docs/chapters/special.sgml
+++ b/docs/chapters/special.sgml
@@ -115,7 +115,7 @@ builder = /usr/bin/git-pbuilder
<sect1 id="gbp.special.hacking">
<title>Working on random packages</title>
<para>
- Whenever you need to work on an arbitrary Debian package you can check it
+ Whenever you need to work on an arbitrary &debian; package you can check it
right into &git; with one command:
<programlisting>
git-import-dsc --download <filename>package</filename>
@@ -126,7 +126,7 @@ git-branch debian
<para>
This uses <command>apt-get</command> to download the source package,
puts the orig tarball on the <option>upstream-branch</option> and the
- Debian changes on the <option>debian-branch</option> (by default
+ &debian; changes on the <option>debian-branch</option> (by default
<emphasis>master</emphasis>). The second command
creates a branch called <emphasis>debian</emphasis>. Now you can easily
modify the package, revert changes you made, create other branches for
@@ -137,7 +137,7 @@ git-diff debian --
</programlisting>
<para>
- to get a nice patch that can be submitted to the Debian BTS. You can also
+ to get a nice patch that can be submitted to the &debian; BTS. You can also
fetch the source package from an URL:
<programlisting>
diff --git a/docs/manpages/gbp-buildpackage.sgml b/docs/manpages/gbp-buildpackage.sgml
index 0e5561ef..8048b1e7 100644
--- a/docs/manpages/gbp-buildpackage.sgml
+++ b/docs/manpages/gbp-buildpackage.sgml
@@ -14,7 +14,7 @@
<refnamediv>
<refname>git-buildpackage</refname>
<refname>gbp-buildpackage</refname>
- <refpurpose>Build Debian packages from a Git repository</refpurpose>
+ <refpurpose>Build &debian; packages from a &git; repository</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
@@ -66,7 +66,7 @@
<refsect1>
<title>DESCRIPTION</title>
<para>
- &gbp-buildpackage; is used to build Debian source and .deb packages from
+ &gbp-buildpackage; is used to build &debian; source and .deb packages from
a &git; repository.
</para>
<para>
@@ -416,7 +416,7 @@
</term>
<listitem>
<para>
- use this tag format when tagging Debian versions, default is
+ use this tag format when tagging &debian; versions, default is
<replaceable>debian/%(version)s</replaceable>
</para>
</listitem>
@@ -435,7 +435,7 @@
<term><option>--git-debian-tag-msg=</option><replaceable>tag-msg-format</replaceable>
</term>
<listitem>
- <para>use this tag message format when signing Debian versions,
+ <para>use this tag message format when signing &debian; versions,
default is <replaceable>%(pkg)s Debian release %(version)s</replaceable></para>
</listitem>
</varlistentry>
@@ -607,7 +607,7 @@
<refsect1>
<title>EXAMPLES</title>
<para>
- Build a Debian package using &git-pbuilder; which in turn invokes
+ Build a &debian; package using &git-pbuilder; which in turn invokes
&cowbuildercmd;. Instruct cowbuilder to build within a Wheezy chroot for
i386.
</para>
diff --git a/docs/manpages/gbp-create-remote-repo.sgml b/docs/manpages/gbp-create-remote-repo.sgml
index e8f6a092..ea22d83d 100644
--- a/docs/manpages/gbp-create-remote-repo.sgml
+++ b/docs/manpages/gbp-create-remote-repo.sgml
@@ -93,7 +93,7 @@
<term><option>--debian-branch</option>=<replaceable>branch_name</replaceable>
</term>
<listitem>
- <para>The branch in the Git repository the Debian package is being
+ <para>The branch in the &git; repository the &debian; package is being
developed on, default is <replaceable>master</replaceable>.</para>
</listitem>
</varlistentry>
diff --git a/docs/manpages/gbp-dch.sgml b/docs/manpages/gbp-dch.sgml
index 8ffdc4f6..22ab5688 100644
--- a/docs/manpages/gbp-dch.sgml
+++ b/docs/manpages/gbp-dch.sgml
@@ -15,7 +15,7 @@
<refnamediv>
<refname>git-dch;</refname>
<refname>gbp-dch;</refname>
- <refpurpose>Generate the Debian changelog from git commit messages</refpurpose>
+ <refpurpose>Generate the &debian; changelog from git commit messages</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
@@ -62,7 +62,7 @@
<refsect1>
<title>DESCRIPTION</title>
<para>
- &gbp-dch; reads git commit messages and generates the Debian changelog from
+ &gbp-dch; reads git commit messages and generates the &debian; changelog from
it. If no arguments are given &gbp-dch; starts from the last tagged Debian
package version up to the current tip of the current branch. If the
distribution of the topmost section in
diff --git a/docs/manpages/gbp-import-dsc.sgml b/docs/manpages/gbp-import-dsc.sgml
index e635a3d9..965cc871 100644
--- a/docs/manpages/gbp-import-dsc.sgml
+++ b/docs/manpages/gbp-import-dsc.sgml
@@ -15,7 +15,7 @@
<refnamediv>
<refname>git-import-dsc</refname>
<refname>gbp-import-dsc</refname>
- <refpurpose>Import Debian packages into a Git repository</refpurpose>
+ <refpurpose>Import &debian; packages into a &git; repository</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
@@ -51,9 +51,9 @@
<refsect1>
<title>DESCRIPTION</title>
<para>
- &gbp-import-dsc; imports a Debian source package into a &git; repository,
+ &gbp-import-dsc; imports a &debian; source package into a &git; repository,
notes the package version in the commit logs, and commits the change. All
- information, including package name, version, Debian diffs, and upstream
+ information, including package name, version, &debian; diffs, and upstream
source is automatically detected from the source package.
</para>
</refsect1>
@@ -105,7 +105,7 @@
</term>
<listitem>
<para>
- use this tag format when tagging Debian versions,
+ use this tag format when tagging &debian; versions,
default is <replaceable>debian/%(version)s</replaceable>
</para>
</listitem>
@@ -125,7 +125,7 @@
</term>
<listitem>
<para>
- Don't create Debian tag after importing the Debian patch. This can be
+ Don't create &debian; tag after importing the &debian; patch. This can be
useful if you already created a package but want to further work on
it after importing it into git.
</para>
@@ -185,7 +185,7 @@
</term>
<listitem>
<para>
- When importing the Debian patch, use the author identity as
+ When importing the &debian; patch, use the author identity as
committer identity.
</para>
</listitem>
@@ -195,11 +195,11 @@
</term>
<listitem>
<para>
- When importing the Debian patch, use the author date as
+ When importing the &debian; patch, use the author date as
committer date.
<warning>
<para>
- Git will subtly misbehave if the committer date of a commit is not
+ &git; will subtly misbehave if the committer date of a commit is not
later than or equal to all its parents.
</para>
</warning>
diff --git a/docs/manpages/gbp-import-orig.sgml b/docs/manpages/gbp-import-orig.sgml
index d6fb2693..6b0993f8 100644
--- a/docs/manpages/gbp-import-orig.sgml
+++ b/docs/manpages/gbp-import-orig.sgml
@@ -80,7 +80,7 @@
<term><option>--[no-]merge</option></term>
<listitem>
<para>
- Merge the upstream branch to the debian branch after import
+ Merge the upstream branch to the &debian; branch after import
</para>
</listitem>
</varlistentry>
@@ -89,7 +89,7 @@
</term>
<listitem>
<para>
- The branch in the Git repository the upstream sources are put
+ The branch in the &git; repository the upstream sources are put
onto. Default is <replaceable>upstream</replaceable>.
</para>
</listitem>
@@ -99,7 +99,7 @@
</term>
<listitem>
<para>
- The branch in the Git repository the Debian package is being
+ The branch in the &git; repository the &debian; package is being
developed on, default is <replaceable>master</replaceable>. After
importing the new sources on the upstream branch, &gbp-import-orig;
will try to merge the new version onto this branch.
@@ -189,7 +189,7 @@
<listitem>
<para>
Whether to create and keep a symlink from the upstream tarball
- to a Debian policy conformant upstream tarball name located in
+ to a &debian; policy conformant upstream tarball name located in
<filename class="directory">../</filename>.
</para>
<para>
diff --git a/docs/manpages/gbp-pq.sgml b/docs/manpages/gbp-pq.sgml
index f1afb04d..ae1c09f3 100644
--- a/docs/manpages/gbp-pq.sgml
+++ b/docs/manpages/gbp-pq.sgml
@@ -37,11 +37,11 @@
<refsect1>
<title>DESCRIPTION</title>
<para>
- &gbp-pq; helps one to manage quilt patches in Debian packages that are
+ &gbp-pq; helps one to manage quilt patches in &debian; packages that are
maintained with &gbp;. This is especially useful with packages using the
3.0 (quilt) source format. With &gbp-pq; you can maintain the quilt patches
that should be applied to a package on a separate branch called patch-queue
- branch. So if your Debian package lives on
+ branch. So if your &debian; package lives on
<replaceable>master</replaceable> the associated patch-queue branch will be
called <replaceable>patch-queue/master</replaceable>.
</para>
@@ -105,7 +105,7 @@
<command>git-am</command>. Use <option>--topic</option> if you want
the patch to appear in a separate subdir when exporting the patch queue
using <option>export</option>. This can be used to separate upstream
- pathes from debian specific patches.
+ pathes from &debian; specific patches.
</para>
</listitem>
</varlistentry>
diff --git a/docs/manpages/gbp.sgml b/docs/manpages/gbp.sgml
index c0fdddc7..4ba7569f 100644
--- a/docs/manpages/gbp.sgml
+++ b/docs/manpages/gbp.sgml
@@ -14,7 +14,7 @@
</refmeta>
<refnamediv>
<refname>&gbp;</refname>
- <refpurpose>Maintain Debian packages in Git</refpurpose>
+ <refpurpose>Maintain &debian; packages in &git;</refpurpose>
</refnamediv>
<refsynopsisdiv>
<cmdsynopsis>
@@ -30,7 +30,7 @@
<refsect1>
<title>DESCRIPTION</title>
<para>
- &gbp; is used to maintain Debian source packages in the &git; version control system.
+ &gbp; is used to maintain &debian; source packages in the &git; version control system.
</para>
</refsect1>
<refsect1>
@@ -88,7 +88,7 @@
<term>import-dsc
</term>
<listitem>
- <para>Import a Debian source package into a &git; repository</para>
+ <para>Import a &debian; source package into a &git; repository</para>
</listitem>
</varlistentry>
</variablelist>
@@ -97,7 +97,7 @@
<term>import-dscs
</term>
<listitem>
- <para>Import several Debian source packages into a &git; repository, sorted
+ <para>Import several &debian; source packages into a &git; repository, sorted
by version number</para>
</listitem>
</varlistentry>