aboutsummaryrefslogtreecommitdiffhomepage
path: root/gbp/git_utils.py
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2008-08-02 15:49:15 +0200
committerGuido Guenther <agx@sigxcpu.org>2008-08-02 15:49:15 +0200
commitdaf11b7cba633ee0422ce3099d8fd120ad17417f (patch)
tree02c148f0d9e8ff286786dc100c764f5f5a116890 /gbp/git_utils.py
parent5a4c2058a872f11aed3101c065f93bf68db13cdd (diff)
parent11e1d9825367657bae6b537c5dd6daba0f48464f (diff)
Merge commit 'debian/0.4.34' into bpo-etch
Conflicts: debian/changelog
Diffstat (limited to 'gbp/git_utils.py')
-rw-r--r--gbp/git_utils.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/gbp/git_utils.py b/gbp/git_utils.py
index 5f6158c6..13845d56 100644
--- a/gbp/git_utils.py
+++ b/gbp/git_utils.py
@@ -96,9 +96,9 @@ class GitRepository(object):
def commits(self, start, end, paths, options):
"""get commits from start to end touching pathds"""
- commits, ret = self.__git_getoutput('log', ['--pretty=format:%H',
- options, '%s..%s' % (start, end),
- '--', paths])
+ commits, ret = self.__git_getoutput('log',
+ ['--pretty=format:%H'] + options +
+ ['%s..%s' % (start, end), '--', paths])
if ret:
raise GitRepositoryError, "Error getting commits %s..%s%s" % (start, end, ["", " on %s" % paths][len(paths) > 0] )
return [ commit.strip() for commit in commits ]