aboutsummaryrefslogtreecommitdiffhomepage
path: root/tests/data/rpm/rpmbuild/SPECS/gbp-test-native2.spec
diff options
context:
space:
mode:
authorMarkus Lehtonen <markus.lehtonen@linux.intel.com>2012-01-12 15:29:03 +0200
committerGuido Günther <agx@sigxcpu.org>2014-07-24 23:33:36 +0200
commite7251f84bc17d585e260091b9efe2dade073982c (patch)
treec83b7b8787549df8a0b4ac5ff783b8cf15331687 /tests/data/rpm/rpmbuild/SPECS/gbp-test-native2.spec
parent1a8e6d12cc94d2b40324fe8f99de012cf2cf5913 (diff)
Introduce rpm helpers
Implements a new gbp.rpm module that contains functionality for e.g. parsing and editing spec files, reading src.rpm files rpm-specific packaging policy etc. Signed-off-by: Markus Lehtonen <markus.lehtonen@linux.intel.com> Signed-off-by: Ed Bartosh <eduard.bartosh@intel.com> Signed-off-by: Zhang Qiang <qiang.z.zhang@intel.com> Signed-off-by: Huang Hao <hao.h.huang@intel.com>
Diffstat (limited to 'tests/data/rpm/rpmbuild/SPECS/gbp-test-native2.spec')
-rw-r--r--tests/data/rpm/rpmbuild/SPECS/gbp-test-native2.spec35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/data/rpm/rpmbuild/SPECS/gbp-test-native2.spec b/tests/data/rpm/rpmbuild/SPECS/gbp-test-native2.spec
new file mode 100644
index 00000000..34fd33dc
--- /dev/null
+++ b/tests/data/rpm/rpmbuild/SPECS/gbp-test-native2.spec
@@ -0,0 +1,35 @@
+Name: gbp-test-native2
+Summary: Test package for git-buildpackage
+Version: 2.0
+Release: 0
+Group: Development/Libraries
+License: GPLv2
+Source: foo.txt
+BuildRequires: unzip
+
+%description
+Package for testing the RPM functionality of git-buildpackage.
+Mimics a "native" package that doesn't have any source tarball.
+
+
+%prep
+# Just create build dir
+%setup -T -c
+cp %{SOURCE0} .
+
+
+%build
+# Nothing to do
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}/%{_datadir}/%{name}
+cp -R * %{buildroot}/%{_datadir}/%{name}
+
+
+
+%files
+%defattr(-,root,root,-)
+%dir %{_datadir}/%{name}
+%{_datadir}/%{name}