summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--tests/data/rpm/specs/gbp-test-tags.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/data/rpm/specs/gbp-test-tags.spec b/tests/data/rpm/specs/gbp-test-tags.spec
index ee4c2b94..443bc8a9 100644
--- a/tests/data/rpm/specs/gbp-test-tags.spec
+++ b/tests/data/rpm/specs/gbp-test-tags.spec
@@ -5,6 +5,9 @@
%define suse_release %(test -e /etc/SuSE-release && head -n1 /etc/SuSE-release | cut -d ' ' -f2 | cut --output-delimiter=0 -d. -f1,2 || echo 0)
%if "%{suse_release}" >= "1201"
%define test_weak_dep_tags 1
+%if "%{suse_release}" < "1302"
+%define test_weak_dep_tags_2 1
+%endif
%endif
%define test_arch_os_tags %(test -n "$GBP_SKIP_ARCH_OS_TAGS" && echo 0 || echo 1)
@@ -54,11 +57,13 @@ Recommends: my_recommends
Suggests: my_suggests
Supplements: my_supplements
Enhances: my_enhances
+%if 0%{?test_weak_dep_tags_2}
BuildRecommends:my_buildrecommends
BuildSuggests: my_buildsuggests
BuildSupplements:my_buildsupplements
BuildEnhances: my_buildenhances
%endif
+%endif
# These should be filtered out by GBP
%if "%{test_arch_os_tags}" != "0"