summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--debian/docs2
-rwxr-xr-xdebian/rules6
-rw-r--r--setup.cfg8
4 files changed, 11 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 4413d2bb..4864fdfe 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,7 +9,6 @@ docs/manual-html/
docs/manpage.links
docs/manpage.refs
docs/version.ent
-docs/apidocs/
debian/git-buildpackage.*.debhelper
debian/git-buildpackage.debhelper.*
diff --git a/debian/docs b/debian/docs
index ccd359db..ce06068d 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1,3 +1,3 @@
README
docs/manual-html/
-docs/apidocs/
+build/apidocs/
diff --git a/debian/rules b/debian/rules
index 5dd5d7b2..89d1a534 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,9 +47,7 @@ docs/git-pbuilder.1: bin/git-pbuilder
pod2man $< $@
apidocs:
- epydoc -v -n git-buildpackage --no-sourcecode -o docs/apidocs/ \
- --url=https://honk.sigxcpu.org/piki/projects/git-buildpackage/ \
- --fail-on-docstring-warning gbp/ tests/test_Git*.py
+ epydoc --config=setup.cfg
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
pychecker:
@@ -77,6 +75,6 @@ binary-post-install/git-buildpackage::
clean::
-rm git_*.py gbp_*.py gbp/gbp_version.py links_stamp
-rm docs/*.1 docs/manpage.* $(VERSION_ENT) git-pbuilder.1
- -rm -r docs/manual-html/ docs/apidocs/
+ -rm -r docs/manual-html/
.PHONY: checks
diff --git a/setup.cfg b/setup.cfg
index 89232640..7dfbe05a 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -2,3 +2,11 @@
with-doctest=1
with-coverage=1
cover-package=gbp
+
+[epydoc]
+name = git-buildpackage
+sourcecode = no
+url = https://honk.sigxcpu.org/piki/projects/git-buildpackage/
+target = build/apidocs/
+fail-on = docstring_warning
+modules = gbp, tests/test_Git*.py