summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
3 files changed, 3 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index f607c3c5..a751aed1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*.pyc
.noseids
+.coverage
gbp/gbp_version.py
gbp_clone.py
gbp_pq.py
diff --git a/debian/control b/debian/control
index 12ef49de..8982c119 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Guido Günther <agx@sigxcpu.org>
Build-Depends: cdbs (>= 0.4.90~), debhelper (>= 5), python (>> 2.6.6-3~),
pychecker, gtk-doc-tools, sgml2x, docbook-utils, jade, python-dateutil, python-nose,
- bash-completion, perl, python-epydoc,
+ bash-completion, perl, python-epydoc, python-coverage,
# For the testsuite
git-core, bzip2, unzip
Standards-Version: 3.9.2
diff --git a/debian/rules b/debian/rules
index d4d6652a..a2bc9215 100755
--- a/debian/rules
+++ b/debian/rules
@@ -65,7 +65,7 @@ checks: links_stamp pychecker
export GIT_AUTHOR_EMAIL=tests@example.com; \
export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
- nosetests --exe --with-doctest
+ nosetests --exe --with-doctest --with-coverage --cover-package=gbp
endif
$(GBP_VERSION): debian/changelog