summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules3
-rw-r--r--setup.cfg4
-rw-r--r--setup.py10
3 files changed, 11 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index b8fccabe..5dd5d7b2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -60,8 +60,7 @@ checks: pychecker
export GIT_AUTHOR_EMAIL=tests@example.com; \
export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
- export PYTHONPATH=$$(pwd); \
- nosetests --exe --with-doctest --with-coverage --cover-package=gbp
+ python setup.py nosetests
endif
$(GBP_VERSION): debian/changelog
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 00000000..89232640
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,4 @@
+[nosetests]
+with-doctest=1
+with-coverage=1
+cover-package=gbp
diff --git a/setup.py b/setup.py
index 767278c3..a57b38c7 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
#!/usr/bin/python
-# Copyright (C) 2006-2011 Guido Guenther <agx@sigxcpu.org>
+# vim: set fileencoding=utf-8 :
+# Copyright (C) 2006-2011 Guido Günther <agx@sigxcpu.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -16,10 +17,10 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
# END OF COPYRIGHT #
-from distutils.core import setup
+from setuptools import setup
-setup(name = "git_build_package",
- author = 'Guido Guenther',
+setup(name = "gbp",
+ author = u'Guido Günther',
author_email = 'agx@sigxcpu.org',
scripts = [ 'bin/git-buildpackage',
'bin/git-import-dsc',
@@ -33,4 +34,5 @@ setup(name = "git_build_package",
'bin/git-pbuilder'],
packages = [ 'gbp', 'gbp.scripts' ],
data_files = [("/etc/git-buildpackage/", ["gbp.conf"]),],
+ setup_requires=['nose>=1.0', 'coverage>=3.4'],
)