aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 00000000..4575b355
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+all: syntax-check test
+
+test:
+ export GIT_AUTHOR_NAME="Gbp Tests"; \
+ export GIT_AUTHOR_EMAIL=tests@example.com; \
+ export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
+ export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
+ PYTHONPATH=. \
+ python setup.py nosetests --with-xcoverage
+
+syntax-check:
+ PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q \
+ gbp gbp.scripts gbp.git gbp.deb
+
+docs:
+ make -C docs
+
+apidocs:
+ mkdir -p build
+ epydoc -v --config=setup.cfg
+
+.PHONY: docs