aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e512cfe8..ad61026f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,5 @@
PY_EXAMPLES=$(shell grep -l /usr/bin/python examples/*)
+FLAKE_OPTS=$(shell test -w /dev/shm || echo '-j1')
all: syntax-check test
@@ -14,8 +15,8 @@ test:
python setup.py nosetests --with-xcoverage
syntax-check:
- flake8 -j1
- flake8 -j1 $(PY_EXAMPLES)
+ flake8 $(FLAKE_OPTS)
+ flake8 $(FLAKE_OPTS) $(PY_EXAMPLES)
docs:
make -C docs