aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ad61026f..cfd997b1 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,6 @@
PY_EXAMPLES=$(shell grep -l /usr/bin/python examples/*)
FLAKE_OPTS=$(shell test -w /dev/shm || echo '-j1')
+NOSE_FLAGS=--with-xcoverage
all: syntax-check test
@@ -12,7 +13,7 @@ test:
export GIT_COMMITTER_NAME=$$GIT_AUTHOR_NAME; \
export GIT_COMMITTER_EMAIL=$$GIT_AUTHOR_EMAIL; \
PYTHONPATH=. \
- python setup.py nosetests --with-xcoverage
+ python setup.py nosetests $(NOSE_FLAGS)
syntax-check:
flake8 $(FLAKE_OPTS)