aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 4e9a43e3..ab675e66 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,7 +29,7 @@ POD_MANPAGES=docs/git-pbuilder.1
MANPAGES=$(SGML_MANPAGES) $(POD_MANPAGES)
MANUAL=docs/manual-html
PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
-PYCHECK_LEVEL=Error
+PYCHECKER_ARGS=--maxlines=300 -boptparse --no-override --no-shadowbuiltin
GBP_VERSION=gbp/gbp_version.py
VERSION_ENT=docs/version.ent
@@ -52,7 +52,7 @@ endif
%.py: %
ln -s $< $@
- PYTHONPATH=. pychecker -e $(PYCHECK_LEVEL) -q $<
+ PYTHONPATH=. pychecker $(PYCHECKER_ARGS) -q $<
$(GBP_VERSION): debian/changelog
echo 'gbp_version="$(DEB_VERSION)"' > $(GBP_VERSION)