summaryrefslogtreecommitdiffhomepage
path: root/tests/11_test_dch_main.py
diff options
context:
space:
mode:
Diffstat (limited to 'tests/11_test_dch_main.py')
-rw-r--r--tests/11_test_dch_main.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/11_test_dch_main.py b/tests/11_test_dch_main.py
index 538d2e84..acea6920 100644
--- a/tests/11_test_dch_main.py
+++ b/tests/11_test_dch_main.py
@@ -57,6 +57,7 @@ class TestScriptDch(DebianGitTestRepo):
self.repo.create_tag("upstream/0.9", msg="upstream version 0.9")
self.add_file("bar", "foo")
self.repo.create_tag("upstream/1.0", msg="upstream version 1.0")
+ self.repo.create_branch("upstream")
self.repo.create_branch("debian")
self.repo.set_branch("debian")
self.upstream_tag = "upstream/%(version)s"
@@ -66,7 +67,7 @@ class TestScriptDch(DebianGitTestRepo):
self.add_file("debian/changelog", cl_debian)
self.add_file("debian/control", """Source: test-package\nSection: test\n""")
self.options = ["--upstream-tag=%s" % self.upstream_tag, "--debian-branch=debian",
- "--id-length=0", "--spawn-editor=/bin/true"]
+ "--upstream-branch=upstream", "--id-length=0", "--spawn-editor=/bin/true"]
self.repo.create_tag(deb_tag, msg=deb_tag_msg, commit="HEAD~1")